Page 1 of 11 123 ... LastLast
Results 1 to 15 of 152

Thread: Microstuttering

  1. #1
    Zombie Hunter Hek Harris's Avatar
    Join Date
    May 2014
    Location
    France
    Posts
    493
    Rep Power
    1

    Microstuttering

    I had a little during the previous alphas, but there, the number has increased.
    I'm lucky to have a PC that can run the game with the settings to max, so I tried all the possible combinations, but it didn't change anything.
    I think it would be interesting to know who has no microstuttering (if there are players who haven't). This would help to know if it is due to some graphics cards, processors or others.
    One thing is certain, something has been changed between A17 and A17.1 which has accentuated this issue.
    I think, Roland, we (you ^^) could create a topic where only players who don't have this problem would communicate their configuration.

  2. #2
    Super Moderator Roland's Avatar
    Join Date
    Feb 2014
    Location
    On a Zipline
    Posts
    13,963
    Rep Power
    2
    Please report if you do NOT experience micro stuttering and your config information.
    Last edited by Roland; 01-10-2019 at 07:20 PM. Reason: oops

  3. #3
    Zombie Hunter Hek Harris's Avatar
    Join Date
    May 2014
    Location
    France
    Posts
    493
    Rep Power
    1
    Thank you, Roland, for moving the post and creating a thread.
    Last edited by Hek Harris; 01-10-2019 at 07:35 PM.

  4. #4
    Reconstructionist
    Join Date
    Jun 2016
    Posts
    704
    Rep Power
    1
    **Crickets**


    =)

  5. #5
    Inventor PoppaTot's Avatar
    Join Date
    Oct 2018
    Posts
    798
    Rep Power
    1
    Quote Originally Posted by Roland View Post
    Please report if you do or do not experience micro stuttering and your config information.
    I do, but very rarely.

    Ryzen 5 2600x
    GTX 1070
    MSI X470 Gaming Plus
    16gb DDR4 Corsair Vengeance 3000
    Kingston SSD
    Win10
    *Play on dedicated server through BlueFang

    EDIT: play windowed mode 1080
    reflections off
    water quality good
    motion blur off
    Last edited by PoppaTot; 01-10-2019 at 07:21 PM.

  6. #6
    Fun Pimps Staff
    Join Date
    Jan 2018
    Location
    Indiana, USA
    Posts
    1,670
    Rep Power
    2
    Kinyajuu and I looked at some code we thought could be causing stuttering and made a change for A17.1 which should have improved it. I have a 60hz monitor and don't really notice a problem. Kin tested it before and after on his 144hz monitor and it seemed better to him.

    This is a subjective problem and probably varies with hardware, so we may not notice or deem it does not bother us, so those with issues will need to describe it in detail or we may never find it. Screenshots or videos could be very helpful.

  7. #7
    Refugee
    Join Date
    Nov 2018
    Posts
    19
    Rep Power
    0
    Had microstutter in 17stable and I no longer have it in 17.1

    Ryzen 1700
    16gb ddr4
    Gtx 1080 ti
    Asus x370 mobo
    Samsung SSD win 10
    144hz monitor
    1080p

    Playing on dedicated server

    Have also noticed higher and more stable frame rates, all settings on lowest except for textures medium

  8. #8
    Tracker TopAce6's Avatar
    Join Date
    Jan 2015
    Location
    Florida, USA
    Posts
    172
    Rep Power
    1
    Im wondering if its possibly related to people's "System Timer" settings.... Such as "HPET" ( https://en.m.wikipedia.org/wiki/High...on_Event_Timer ) there's a lot of jankiness/conflicts between drivers/OS/Bios/UEFI/id10t all having different settings.

    Mine is turned off so i have the lowest possible system latency (my OS/UEFI is highly optimized, so i really don't have many problems)

  9. #9
    Tracker hotpoon's Avatar
    Join Date
    Jul 2016
    Location
    South Africa
    Posts
    183
    Rep Power
    0
    I had microstutter in A17.0 and now in A17.1 it seems to be fixed now, so long as I don't enable the 2 reflection options - then the stutter returns. Everything else is on high/best settings.

  10. #10
    Leader Fox's Avatar
    Join Date
    Oct 2013
    Location
    Under the snow
    Posts
    5,532
    Rep Power
    1
    Quote Originally Posted by faatal View Post
    Kinyajuu and I looked at some code we thought could be causing stuttering and made a change for A17.1 which should have improved it. I have a 60hz monitor and don't really notice a problem. Kin tested it before and after on his 144hz monitor and it seemed better to him.

    This is a subjective problem and probably varies with hardware, so we may not notice or deem it does not bother us, so those with issues will need to describe it in detail or we may never find it. Screenshots or videos could be very helpful.
    With all the movement animations, some ppl can find it difficult to notice the stutters, especially depending on hardware / software configs as you mentioned... but in flight mode, especially when going around an object... it's impossible for anyone to not see it.

    Hope that helps in seeing it.

  11. #11
    Hunter
    Join Date
    Jan 2019
    Posts
    113
    Rep Power
    0
    I don't have any micro stutter. Posted numerous posts on making the game look and perform better, and for me it does. Only time I notice microstutter is using god/fly mode while the terrain loads.

    https://7daystodie.com/forums/showth...ie-Look-Better
    https://7daystodie.com/forums/showth...lk-Performance
    Last edited by ghettochild2600; 01-11-2019 at 12:27 AM.

  12. #12
    Refugee
    Join Date
    Mar 2018
    Posts
    2
    Rep Power
    0
    I have some minute stutter as of 17.0 stable. I host a game with 4 people including myself so some of the strain on my system may be from hosting. (We play usually for a few hours a night but hadn't played tonight so everyone hadn't updated to 17.1 yet, will give an update with more info if I have any change).
    CPU: Ryzen 5 1600x
    RAM: 16gb 3200mhz DDR4 Corsair Vengeance
    Motherboard: ASRock AB350 Gaming K4
    GPU: AMD Radeon R9 290

    Game Settings: Reso- 1680x1080. Fullscreen. V-Sync. Anti-Aliasing on. Texture Quality- Full. UMA Texture Quality- High. Reflection- Low. Reflected Shadows- No. Shadow Distance- Near. Water Quality- High. Water Particles- 50%. View Distance- Medium. LOD Distance- 50%. Tree Quality- Ultra. Grass Distance- Normal. Motion Blur- Normal. SSAD- Yes. Depth of Field- Yes. Sun Shafts- Yes.

  13. #13
    Hunter The_Great_Sephiroth's Avatar
    Join Date
    Aug 2017
    Posts
    121
    Rep Power
    0
    I did prior to getting G-Sync working with the new Unity engine. Now it is normally liquid-smooth, but once in a while it actually does a full stutter, like it is loading something off of an old EIDE disk or something, but normally only after thirty minutes or more of gameplay. The game is actually on a RAID0, so loading should never be an issue.

    i7-6950X
    32GB DDR4-3200 (Corsair)
    1TB WD Blue on AHCI controller (OS, programs)
    2TB RAID0 on RAID controller (two 1TB WD Black disks) mounted at C:\Games (Steam and other games here, duh)
    Two GTX1070's in SLI using the high-bandwidth SLI bridge
    Mobo is an ASRock X99 Extreme4
    Dual-Layer Blu-Ray burner on the AHCI controller
    750W Gold PSU (I forget the model)
    Creative AE5 AUdio Card
    Dell S2417DG 24", 1440p (2560x1440), 144HZ G-Sync Monitor

    All in-game settings are maxed. I get about 40-80fps depending on the area.

  14. #14
    Ranger CoolJ's Avatar
    Join Date
    Dec 2014
    Posts
    283
    Rep Power
    1
    Are those of you who are experiencing micro stutter playing with Vertical Sync turned on or off? The only stutters I ever get are clearly problems with garbage collection and tend to happen when spawns populate. I had some actual micro stutter problems after I had to rebuild this machine a few months ago. Turns out my video card was not seated correctly and was not ever switching into PCI-E X16 mode. It went away after I reseated it. That is the problem with big heavy cards. They can be a PITA sometimes.

    I have not had any problems otherwise. I do notice that a lot of people play with V-Sync turned off. That may not be helping here. Also, make sure you aren't running any game specific setting changes in your control panel. Such as forcing AA or AF on the video driver end. This game does not like that at all.

  15. #15
    Tracker Greymantle's Avatar
    Join Date
    Apr 2015
    Posts
    234
    Rep Power
    0
    17.0 I had very little stutter with 17.1 so far it has increased a lot. I have a 6500 skylake I5, GTX 1060, 16gb of ram, Creative sound card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •