Results 1 to 6 of 6

Thread: Base reverted

  1. #1
    Refugee LadyGrelka's Avatar
    Join Date
    Sep 2019
    Posts
    3
    Rep Power
    0

    Angry Base reverted

    When I started my saved game for my single player, Navezgane world (game version 17.4) the house I spent MANY hours upgrading and reinforcing had reverted back to the original state I found it in, and all my chests I put down with my stuff in them where gone, as well as the furniture I placed in my house, my claim block was also gone, I had planted crops and all but a few where gone as well, however the wall I built on my claim border was still there, as well as the few things I had in my inventory. I have looked around the forum and have seen similar problems but they are all on servers and it seems they happened after the game crashed, or while in game when they get back from exploring. My game did NOT crash, I played last night, cleaned out my inventory from my exploration trip and exited the game with no problems what so ever, then when I loaded my save today my house had reverted like I explained above. I am not happy, that house took a lot of work and now I have to start over, because I have found no way to rollback my save to an earlier date, soo frustrating. Does anyone know what causes this problem and how to fix it or avoid it?

  2. #2
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    8,455
    Rep Power
    1
    Need the log from when you loaded that save and the base showed missing.

  3. #3
    Refugee LadyGrelka's Avatar
    Join Date
    Sep 2019
    Posts
    3
    Rep Power
    0
    Ok, I think this is the right log, I logged in a few times hoping that it would fix itself, I know wishfull thinking on my part. output_log__2019-09-08__18-40-18.txt

    I could also provide the log from before my base reverted to what it was when I found it if that helps.

  4. #4
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    8,455
    Rep Power
    1
    Thank you. I was hoping to see if there was an error generated when loading it.

    Code:
    2019-09-08T18:45:39 276.465 ERR EXCEPTION: In load chunk (chunkX=-106 chunkZ=48)2019-09-08T18:45:39 276.466 EXC Failed to read past end of stream.
    EndOfStreamException: Failed to read past end of stream.
      at PooledBinaryReader.FillBuffer (Int32 _numBytes) [0x00000] in <filename unknown>:0 
      at PooledBinaryReader.ReadString () [0x00000] in <filename unknown>:0 
      at TileEntitySecureLootContainer.read (System.IO.BinaryReader _br, StreamModeRead _eStreamMode) [0x00000] in <filename unknown>:0 
      at Chunk.read (System.IO.BinaryReader _br, UInt32 _version, Boolean _bNetworkRead) [0x00000] in <filename unknown>:0 
      at Chunk.load (System.IO.BinaryReader stream, UInt32 _version) [0x00000] in <filename unknown>:0 
      at RegionFileManager.loadChunk (System.String _dir, Int64 _key) [0x00000] in <filename unknown>:0 
    UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    UnityEngine.Logger:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    Logger:masterLogException(Exception)
    Logger:Exception(Exception)
    Log:Exception(Exception)
    RegionFileManager:loadChunk(String, Int64)
    RegionFileManager:GetChunkSync(Int64)
    ChunkProviderGenerateWorld:DoGenerateChunks()
    ChunkProviderGenerateWorld:thread_GenerateChunks(ThreadInfo)
    ThreadManager:myThreadInvoke(Object)
     
    (Filename:  Line: -1)
    
    
    2019-09-08T18:45:39 276.471 ERR Stream position: 75489, length: 75489, compressed length: 6738
    Looks like there was an error in the chunk data for the region file, so the corrupt chunk was re-generated. This explains why your base got replaced with stock landscape.

    Was there any error in the previous playthough, or did the game not get shut down correctly?

  5. #5
    Refugee LadyGrelka's Avatar
    Join Date
    Sep 2019
    Posts
    3
    Rep Power
    0
    As i said, I played the night before and everything was fine, no crash, or errors and when I was done I exited the game with no problems.

  6. #6
    Ranger Beelzybub's Avatar
    Join Date
    Dec 2015
    Posts
    318
    Rep Power
    1
    Maybe the log from the night before, (the last time you played with an intact base) will show something.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •