PDA

View Full Version : Multiplayer Dedicated server on Mac OS X - In-game time resets after couple of seconds



Nemiel
08-23-2014, 10:02 PM
Me and my friend are playing on a private dedicated server hosted on either my or his machine, which we simultaneously use as a client. This sometimes leads to severe lags when massive hordes of zombies are spawning. Therefore I wanted to use my MacBook Pro to run the server, which at the first glance worked fined...but is not.

First I created a dedicated server using the alpha v9.1 build of 7d2d following the instructions from here (http://www.7daystodie.com/forums/showthread.php?1154-Hosting-on-MacOSX). in short, I copied the xml files serveradmin.xml and serverconfig.xml into the 7daysToDie.app package next to the folders Contents and data. Then I created the txt file to start the dedicated server according to the instructions in the link above, replacing the path with my path of the app and adjusting the telnet port (i had to enable PLAIN text when editing the txt or xml files with textedit on mac link (http://support.apple.com/kb/ta20406)). After manually converting the txt file into an executable file by using the terminal and the command without the quotes

chomod -x "path to file location"

After redirecting the protforwarding in my router from my PC to my MacBook I can start the server by double clicking on the executable file. Telnet does not connect in my case and I do not know the cause since the port is open, but I can access the server wia webpage control panel on port 8080 (after i have to enter my administrator passwort into a pop-up for accepting incoming internet connections...I will have to create a certificate for this executable).

Using my external IP for my friend or my local Mac IP for myself we both are able to enter the world on the dedicated server. I also have permissioned administrator rights on the in-game console with my pc. Even copying our existing world from the PC to the macīs appropiate world folder worked fine and we could access our old world with the saved characters! Great! everything looked fine. The lags were gone and playing was super smooth. Then we discovered the big problem which I have no clue is causing it! The day never passed...

THE PROBLEM:
-The in-game time in the upper left corner (say starting at 8:00) ticks very slowly often jumping one or two seconds forth and back until after ~15 sec the time completely jumps back to 8:00...resulting in actually destroying the game experience und fun

My previous attempts to find the cause or solution of the lag/reset:
-restarting the Macbook didnīt help
-Setting the time to any other value via the settime command does not change the behavior at all. It always jumps back after more or less 15 seconds.
-when using the debugging mode command and opening the panel with F1, I see that the time listed there behaves exactly like the time in the corner and jumps back at the very same instant (the number above...i canīt remember what its called...is ticking normally without lag)
-the number of clients does not have any effect and being a client on the same macbook does also not alter this behavior.
-during lag/reset of the time there is no peak in extreme data transfer (monitored by activity monitor) as well as cpu usage (monitored using the terminal command "top -o CPU -n 10"
-a newly created world on the Mac behaves similar (ruling out that the world file from the PC was corrupt after transfer)

The specs of my Mac are:

MacBook Pro Retina 13"
OS X 10.9.4
2.9 GHz Intel Dual Core i7
8 GB 1600 MHz DDR3

Internet: DSL with 16 mbit down- and 1mbit upload

Meanwhile we play again on our PCs, since I donīt get the admission right on may PC (even though on the mac it worked, with the very same admin file) my friend is hosting the server, but again we have to deal with massive lags so its definately not a solution. I would really appreciate any kind of help with that problem or if anyone has encountered similar problems (on mac or pc)!

Nemiel
08-23-2014, 10:15 PM
Dammit, I messed up the title :/ editing doesnt help to change it in the thread list...hope someone still looks into this one...

Nemiel
09-02-2014, 06:08 PM
Still couldnīt figure out where the problem is. Was hoping to to know if anyone can host a server on a mac without any problems at all.

Grey_Seer
09-05-2014, 03:59 AM
Hello,

Got the same problem, the time was working correctly, but at 19h40-19h50 the time started to slow down and after some minutes, it start looping.

We were 4 players online.

restarting the server didn't solve the issue. We are now jam at Day 1, with a clock looping.

This is a dedicated server hosted on a VM (Windows 2008R2). 1 of the 4 core is at 100% used when this bug append. Memory usage was fine, the server was using the same % of memory as 9.1.