PDA

View Full Version : Crash Huge memory leak



Melen
12-13-2015, 06:12 PM
I'm running the Linux dedicated server on Ubuntu 14.04 64bit. Both the 32bit and 64bit servers eventually consume all of the RAM available. The server is running with 6 3.33Ghz CPU cores and 16GB of RAM. I originally had 8GB of RAM, which alpha 12 ran on for quite awhile with very few issues. So I up'd the server to 16GB, and all that did was give a little more play time before crashing.

After a couple hours, using the 64bit server version (7DaysToDieServer.x86_64), all 16GB eventually gets used up and the server crashes with:


2015-12-13T12:59:05 45732.041 INF Adding observed entity: 3879, (720.0, 0.0, 1040.0), 3
Using memoryadresses from more that 16GB of memory

(Filename: Line: 121)

Nothing else is showing in the logs. A quick look at RAM usage shows the server process using all 16GB of RAM.

The 32bit server version is even worse. I maybe get an hour of play, with only 2 players, before it crashes. Here's the output of that crash:


Could not allocate memory: System out of memory!
Trying to allocate: 4194304B with 16 alignment. MemoryLabel: STL
Allocation happend at: Line:81 in
Memory overview

[ ALLOC_DEFAULT ] used: 2222635474B | peak: 2222804311B | reserved: 2245496654B
[ ALLOC_TEMP_JOB ] used: 69812351B | peak: 0B | reserved: 67108864B
[ ALLOC_GAMEOBJECT ] used: 78154045B | peak: 109605159B | reserved: 86837463B
[ ALLOC_GFX ] used: 199026847B | peak: 352807123B | reserved: 199128991B
[ ALLOC_PROFILER ] used: 0B | peak: 0B | reserved: 0B
Could not allocate memory: System out of memory!
Trying to allocate: 4194304B with 16 alignment. MemoryLabel: STL
Allocation happend at: Line:81 in
Memory overview

[ ALLOC_DEFAULT ] used: 2222635474B | peak: 2222804311B | reserved: 2245496654B
[ ALLOC_TEMP_JOB ] used: 69812351B | peak: 0B | reserved: 67108864B
[ ALLOC_GAMEOBJECT ] used: 78154045B | peak: 109605159B | reserved: 86837463B
[ ALLOC_GFX ] used: 199026847B | peak: 352807123B | reserved: 199128991B
[ ALLOC_PROFILER ] used: 0B | peak: 0B | reserved: 0B


(Filename: Line: 980)

So there appears to be a huge memory leak somewhere. I am not using Aloc's server fixes. It happens with or without them. It's especially bad because it tends to reset the day. I've gotten as far as day 8, had a out of memory crash, and when I logged back in it was day 1.

Thanks.

Addle
12-13-2015, 07:46 PM
Exactly the same here. And the Linux client also has a large memory leak.

Wii5
12-15-2015, 01:27 PM
Same problem yesterday! 3 crashes in about 2 hours! error with A13 and A13.1!


[email protected]:~/DS$ cat /etc/debian_version
8.2



[email protected]:~/DS$ ldd --version
ldd (Debian GLIBC 2.19-18+deb8u1) 2.19
Copyright (C) 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

abarham
12-15-2015, 05:25 PM
The server we run has the same issues. It's about ever 2 -3 hours then it crashes. Server gets to 2 gigs of used memory fairly quickly then just climbing up. Exploring new areas or having a 7-day horde show up seems to speed up the process.

This is happening in 13.0, 13.1, 13.2 -- oddly enough 13.0 seemed the best overall with OOM crashes, and 13.1 and 13.2 slightly worse.

Thanks.

Justflixit
12-16-2015, 07:04 AM
Yeah, same here!

We just work arround this issue by executing "saveworld " from time to time and having a script that restarts the server.

But nonetheless this is annoying as hell!

baird 888
12-16-2015, 08:49 AM
I really hope this gets fixed soon...my server has to restart ever 6 hours or else it runs out of memory and things get super laggy

Nicolayka
12-16-2015, 05:41 PM
I have the same problem since version 13!