PDA

View Full Version : [PS4] farming underground bugged?



LordViperScorpion
07-31-2016, 12:03 AM
So I built a farm underground with 9 shafts going to the surface about two blocks apart in a rough rectangle, filled them with glass and put down dirt. I am seeing plants disappear when planting the next one as if they dont have enough light. Corn seems to be oblivious to this and seems to go down wherever but potatoes or blueberries seem to replace each other most of the time.

is there a trick to how light affects fertile dirt? laid down first? dig it all back up? or ? I have read up on the mechanics of it so technically I should be able to do about a 12 x 20 garden down there no problem. I assume it's the lack of light mechanic kicking in or is this just bugged? again corn seems to resist this for whatever reason. I placed corn in between a spot where potato, coffee and blueberry were just replacing each other and the corn went down.

Are there differing light requirements that I have overlooked? or a degradation by distance clause in place since I am at bedrock?

I can dig more glass shafts but based on what I've read I shouldn't have to.

Doombringer101
07-31-2016, 09:08 AM
Does the fertile dirt go green and grass grows after a while?
If so then you are getting enough light.
I know this sounds stupid but did you hoe the soil before planting everything but the corn?
Corn grows on grass blocks but most other crops wont.

MrSmoke
07-31-2016, 11:53 AM
I have a small underground farm that works perfectly. Its 8x6 in size and everything ive planted there grows perfectly.

I kept it realatively close to the surface though in an effort to ensure enough light got it.

Instead of using glass blocks i opted for iron bars. I put a 2 block wide shaft to the surface going down the length of the roof and closed it off with iron bars. Lets rain in too which was another reason i used the bars over glass. I doubt it needs the rain water, but wanted a bit more realism.

LordViperScorpion
07-31-2016, 06:11 PM
hmm well I think it was a glitch of some type because after the corn grew up I threw down a ton of potatoes and blueberries and they stopped replacing each other. nothing in the garden changed. grass grew, corn had no issues and 1 or 2 of the other crops went down on multiple different spots, they just kept going crunch and disappearing. As far as using the hoe, I never do on any of the gardens I just throw down fertile dirt and plant immediately, has never been an issue on my other gardens. I dig it up and have seeds ready when I harvest. I was at bedrock under a hill so the depth was a good 67 -70 meters. I read somewhere that distance shrinks the mechanic with some fillers but I don't know if that is an old mechanic or untrue or what. Some thread from 2015 said that the radius is smaller if you use windows so I reasoned that maybe it was something similar since I used like 60 glass blocks.

Now I added another shaft thats all grates so there isn't a way to test if the issue was business glass shaft. I was half inclined to replace them all but that doesn't seem to have been the actual issue. It was a multi-step process so I am guessing something didn't trigger correctly at first but did after I left for a couple days.