Page 2 of 5 FirstFirst 1234 ... LastLast
Results 16 to 30 of 74

Thread: REV6:7-8's REALITY CHECK

  1. #16
    Refugee
    Join Date
    Dec 2018
    Posts
    23
    Rep Power
    0
    i like this, is there a option to have them all except ferals? have you done a mod that removes them?

  2. #17
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    @delukard,

    I may add a modlet to remove ferals at some point, but my modlet package does not currently have a modlet to address that at this time.

    THAT SAID... you can nerf them for yourself from the game options screens.

    A feral zombie runs day or night, and hits a bit harder. Take away the "running," and they're really not all that much harder to deal with than non-ferals.

    If you keep an eye on your stamina, non-running ferals are reasonably easy to kite with a bow, or hit and run with melee weapons.

    On the BASIC tab, change ZOMBIE FERAL SPEED to WALK, and you now have non-running feral zombies.

    makeferalswalk.jpg

    Hope this helps, and cheers!
    REV6:7-8

  3. #18
    Tracker OzzFreak's Avatar
    Join Date
    Feb 2014
    Location
    http://www.zombiestomp.net/
    Posts
    236
    Rep Power
    0
    yeah there is a problem when they go to spawn a wandering horde

    Code:
    2019-01-02T19:53:44 7335.293 INF AIDirector: Spawning wandering horde2019-01-02T19:53:44 7335.294 INF AIDirector: FindWanderingHordeTargets at player '[type=EntityPlayer, name=Tyger-Blud, id=9980]', dist 54.13451
    2019-01-02T19:53:44 7335.294 INF Party with 3 player(s) has a computed game stage of 8
    2019-01-02T19:53:44 7335.294 INF Party members: 
    2019-01-02T19:53:44 7335.294 INF Player id 9980 gameStage: 47
    2019-01-02T19:53:44 7335.294 INF Player id 9024 gameStage: 81
    2019-01-02T19:53:44 7335.294 INF Player id 171 gameStage: 115
    InvalidCastException: Cannot cast from source type to destination type.
      at AIWanderingHordeSpawner.UpdateSpawn (.World _world, Single _deltaTime) [0x00000] in <filename unknown>:0 
      at AIWanderingHordeSpawner.Update (.World world, Single _deltaTime) [0x00000] in <filename unknown>:0 
      at AIDirectorWanderingHordeComponent.TickActiveSpawns (Single dt) [0x00000] in <filename unknown>:0 
      at AIDirectorWanderingHordeComponent.Tick (Double _dt) [0x00000] in <filename unknown>:0 
      at AIDirector.ComponentsTick (Double _dt) [0x00000] in <filename unknown>:0 
      at AIDirector.Tick (Double dt) [0x00000] in <filename unknown>:0 
      at World.OnUpdateTick (Single _partialTicks, ArraySegment`1 _activeChunks) [0x00000] in <filename unknown>:0 
      at GameManager.gmUpdate () [0x00000] in <filename unknown>:0 
      at GameManager.Update () [0x00000] in <filename unknown>:0 
     
    (Filename:  Line: -1)

    then the server just locks up. it went a whole 4 hours no problem, this was jsut after a blood moon horde

  4. #19
    Tracker OzzFreak's Avatar
    Join Date
    Feb 2014
    Location
    http://www.zombiestomp.net/
    Posts
    236
    Rep Power
    0
    prior to this i had no dogs no radiated and no vultrues going for 2 blood mons no problem, then this just happened for no reason. i havent changed any mods since yesterday.

  5. #20
    Tracker OzzFreak's Avatar
    Join Date
    Feb 2014
    Location
    http://www.zombiestomp.net/
    Posts
    236
    Rep Power
    0
    only difference i see is in no radiated you have animalZombieVultureRadiated replaced with animalChicken
    and in no vultures you have animalZombieVultureRadiated replaced with animalDoe

    so 1 rad vulture getting removed and replaced with 2 animals and the system trying to keep it number of animals alive and zombies alive

    ?? maybe ??

  6. #21
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    OzzFreak,

    I'm not doing a direct substitution of any NPCs in any of the modlets. Two (2) things are happening, speaking strictly about running the NO RADIATED and NO VULTURES modlets within the same game install...

    1. I'm removing the NPCs specified from all entity groups in the entitygroups.xml file. In your examples, animalZombieVultureRadiated, (REMEMBER, modlets load ALPHABETICALLY)...

    NO RADIATED:

    <remove xpath="/entitygroups/entitygroup/entity[@name='animalZombieVultureRadiated']" />

    SUCCESS

    NO VULTURES:

    <remove xpath="/entitygroups/entitygroup/entity[@name='animalZombieVultureRadiated']" />

    THROWS A WARNING THAT THIS IS NOT APPLIED, AS IT'S ALREADY GONE PER NO RADIATED

    2. I'm appending an animal only into those entity groups that would be otherwise left empty, because empty entity groups cause issues with entitygroups.xml (and sometimes spawning.xml).

    NO RADIATED:

    <append xpath="/entitygroups/entitygroup[@name='ZombieFeralRadiatedGroup']">
    <entity name="animalChicken"/>
    </append>

    NO VULTURES:

    <append xpath="/entitygroups/entitygroup[@name='EnemyAnimalsWasteland']">
    <entity name="animalDoe"/>
    </append>

    <append xpath="/entitygroups/entitygroup[@name='VultureGroup']">
    <entity name="animalDoe"/>
    </append>

    I'm actually doing "step 2" before "step 1," to ensure that groups are not empty at any point in the load process.

    So, if you're running both NO VULTURES and NO RADIATED, the sequence of events is...

    1. animalChicken gets appended into the ZombieFeralRadiatedGroup entity group (by NO RADIATED)

    2. animalZombieVultureRadiated gets removed from all entity groups (by NO RADIATED)

    3. animalDoe gets appended into the EnemyAnimalsWasteland and VultureGroup entity groups (by NO VULTURES)

    4. animalZombieVultureRadiated is ATTEMPTED to be removed (by NO VULTURES), but throws a warning because it's already removed per NO RADIATED.

    That's it. That's as complicated as those two modlets get, including their interactions between them.

    In your particular situation, where you suspect modlets to be the culprit for your server crash(es), once again, I would advise you to go back through the troubleshooting steps I outlined for you previously (stopping the game/server, removing all mods/customizations, testing the base install for proper function and/or re-installing your base install, re-adding modlets one by one, re-starting the game, carefully watching the error console, checking for proper functionality, stopping the game, rinse and repeat).

    I can only speak with any authority about what MY modlets do and how they interact with the base/vanilla 7DTD Alpha 17 install, not about how other modlet(s) from other author(s) may cause unexpected situations. Maybe try running your game/server with only my modlets, no other modlets or customizations, and see if you get the same issues. If so, then my modlets may be culprit. If not, you'll want to take the issue up with the author(s) of the offending modlet(s).

    When in doubt, strip it out. Try to remove as many variables as you can while trying to troubleshoot this issue. Otherwise, I might be trying to troubleshoot someone else's mistakes, or vice versa.

    Hope this helps, and cheers!
    REV6:7-8

    Quote Originally Posted by OzzFreak View Post
    only difference i see is in no radiated you have animalZombieVultureRadiated replaced with animalChicken
    and in no vultures you have animalZombieVultureRadiated replaced with animalDoe

    so 1 rad vulture getting removed and replaced with 2 animals and the system trying to keep it number of animals alive and zombies alive

    ?? maybe ??

  7. #22
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    Quote Originally Posted by OzzFreak View Post
    prior to this i had no dogs no radiated and no vultrues going for 2 blood mons no problem, then this just happened for no reason. i havent changed any mods since yesterday.
    ... and what mods did you change yesterday? The devil is in the details. Please be as specific as you can.

    - - - Updated - - -

    After decades of providing IT support, one thing is pretty certain. When a customer tells me "it was working great, but I changed XYZ yesterday and now it's not," XYZ probably broke it.

  8. #23
    Tracker OzzFreak's Avatar
    Join Date
    Feb 2014
    Location
    http://www.zombiestomp.net/
    Posts
    236
    Rep Power
    0
    Quote Originally Posted by rev678 View Post
    ... and what mods did you change yesterday? The devil is in the details. Please be as specific as you can.

    - - - Updated - - -

    After decades of providing IT support, one thing is pretty certain. When a customer tells me "it was working great, but I changed XYZ yesterday and now it's not," XYZ probably broke it.
    https://csmm.catalysm.net/

    is the only thing changed
    only mods intalled are
    Allocs
    csmm
    No rad
    No Dogs
    No Vultures


  9. #24
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    Quote Originally Posted by OzzFreak View Post
    https://csmm.catalysm.net/

    is the only thing changed
    In situations where everything was working before one thing was changed, I would start by removing that one thing and re-testing.

    If you've tried the troubleshooting steps I've outlined a couple of times now, without success, and are still having this particular issue, then perhaps this modlet package may not be a good fit within your existing setup.

    Maybe try stripping what you believe to be the offending modlets (i.e., my reality check modlet package) from your installation, and running the game for a similar period of time with a similar load (player logins) as you did when you encountered the issues. If removing my modlets from your server and running the game for an extended period of time does NOT produce similar error conditions, then my modlets were definitely to blame, and you should cease using them in your environment.

    THAT SAID, if removing my modlets from your server and running the game for an extended period of time DOES produce similar error conditions, then my modlets were definitely NOT to blame, and you should contact the author(s) of the other modlet(s) and/or customization(s).

    If you end up being the only person to have and/or report this particular error condition to me, then I may not be able to dedicate my time and energies to helping you troubleshoot this much further. In that case, it may be beneficial for you remove those modlets from your server, to ensure the continued accessibility and reliability of your server environment for your customer/player base.

    That's the beauty of free software. If it doesn't work as well for you as it does for other people, you can always remove it and try something else.

    Hope this helps, and cheers!
    REV6:7-8

  10. #25
    Tracker OzzFreak's Avatar
    Join Date
    Feb 2014
    Location
    http://www.zombiestomp.net/
    Posts
    236
    Rep Power
    0
    yeah i have ran my server set up for 4 years with no problems
    i found a problem
    im deleting the problems
    thanks
    and i hope THAT helps

  11. #26
    Hunter
    Join Date
    Jun 2015
    Posts
    147
    Rep Power
    0
    Wow, why haven't I noticed this mod before? Dogs have been making my gameplay terrible since the day they appeared. Also, what do I do if I want to delete them instead of replacing them?

  12. #27
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    Quote Originally Posted by MaxTunnerX View Post
    Wow, why haven't I noticed this mod before? Dogs have been making my gameplay terrible since the day they appeared. Also, what do I do if I want to delete them instead of replacing them?
    If you merely delete the dogs from all entity groups in entitygroups.xml using the NO DOGS modlet...

    <remove xpath="/entitygroups/entitygroup/entity[@name='animalZombieDog']" />

    ... then it's possible to end up with empty entity groups, depending on what NPCs other modlets may be removing.

    Empty entity groups cause entitygroups.xml to fail to load properly, which can also cause issues with spawning.xml. If you then try deleting the empty entity groups, then spawning.xml ends up failing. If you remove all references to all of the empty entity groups from spawning.xml, it becomes a big PITA.

    By adding different NPCs into groups that might otherwise be emptied during the removal, we avoid all of those problems...

    <append xpath="/entitygroups/entitygroup[@name='EnemyAnimalsWasteland']">
    <entity name="animalStag"/>
    </append>

    <append xpath="/entitygroups/entitygroup[@name='ZombieAnimalsGroup']">
    <entity name="animalStag"/>
    </append>

    <append xpath="/entitygroups/entitygroup[@name='ZombieDogGroup']">
    <entity name="animalStag"/>
    </append>

    It's not a pure replacement, as the animalStag NPC is only added into those entity groups at risk of becoming empty groups, given the very real possibility of people running any combination of my modlets.

    Hope this explains, and cheers!
    REV6:7-8

  13. #28
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    Quote Originally Posted by OzzFreak View Post
    yeah i have ran my server set up for 4 years with no problems
    i found a problem
    im deleting the problems
    thanks
    and i hope THAT helps
    Oh, it does.

    OzzFreak > /dev/null 2>&1

  14. #29
    Hunter rev678's Avatar
    Join Date
    Dec 2018
    Posts
    109
    Rep Power
    1
    Quote Originally Posted by delukard View Post
    i like this, is there a option to have them all except ferals? have you done a mod that removes them?
    1. Added a new modlet:

    NO FERALS - This modlet removes all feral zombies.

    2. Updated OP to provide additional information about the new modlet.

    Hope this helps, and cheers!
    REV6:7-8

  15. #30
    Hunter
    Join Date
    Jun 2015
    Posts
    147
    Rep Power
    0
    Oh okey, I will keep them in the game then. Looking forward to the feral horde with chickens and stags in it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •