Results 1 to 2 of 2

Thread: Save corruption and crash after load (ArrayTypeMismatchException) [A17 Stable]

  1. #1
    Join Date
    Dec 2018
    Rep Power

    Save corruption and crash after load (ArrayTypeMismatchException) [A17 Stable]

    Summary: Crash and savegame corruption
    Version: Alpha 17 build 240 (Stable)
    Platform: PC
    OS/Version: Windows
    Number of players: 1 (Single play)

    Did you wipe old saves? Yes
    Did you start a new game? Yes
    Did you validate your files? Yes
    Reproducible? Reproduces itself unfortunately, no quick repro found yet

    Are you using any mods? No
    EAC on or off? On

    Happened with two of my saves, once after 3 days, the second time during the 9th night or so.

    After loading, the debug console starts flooding ArrayTypeMismatchException errors, then the game crashes with a bunch of NullReferenceExceptions. Afterwards the save cannot be loaded, the process hangs.

    I've tried verifying game files, but they were alright. Also tried deleting the save's Region folder, but did not improve matters one bit.

    I've attached today's logs.


    Could not find the crash log in the directory mentioned in the log files, so I cannot attach that.

  2. #2
    Join Date
    Sep 2019
    Rep Power
    long story short i was having same issue...

    I disable EAC (Easy Anti-Cheat) in the server config file since i'm just playing solo, or with a friend of mine...

    problem solved (imagine my shock)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts