Results 1 to 5 of 5

Thread: Dedicated server wont start

  1. #1
    Hunter
    Join Date
    Jan 2014
    Posts
    126
    Rep Power
    0

    Dedicated server wont start

    Hello All,

    Its been a awhile since ive been here, but im back. And i need to pick your brains to solve this one.

    I am trying to run a dedicated server with just a few changes to the Server config file, when I start it with the vanilla Config file it starts and runs properly, yet when i change the settings for the name, and making the zombies jog instead of run, it wont work.

    I moved the dedicated server folder from the Steam folder and placed it on the Desktop, but i do not think that should do anything.

    Thanks

    Code:
    <?xml version="1.0"?>
    <ServerSettings>
      <property name="ServerPort" 				value="26900"/>				
      <property name="ServerVisibility"			value="2"/>				
      <property name="ServerName" 				value="razorbois world"/>		
      <property name="ServerPassword" 			value="zed"/>					
      <property name="ServerMaxPlayerCount" 	value="8"/>					
      <property name="ServerReservedSlots"		value="0"/>					
      <property name="ServerReservedSlotsPermission"	value="100"/>		
      <property name="ServerAdminSlots"			value="0"/>					
      <property name="ServerAdminSlotsPermission"	value="0"/>				
    
      <property name="ServerDescription" 		value="Razorbois world"/> 
      <property name="ServerWebsiteURL" 		value=""/>					
      <property name="ServerDisabledNetworkProtocols"	value="SteamNetworking"/>			
    
      <property name="GameWorld" 				value="RWG"/>			
      <property name="WorldGenSeed" 			value=""/>				
      <property name="WorldGenSize" 			value="8192"/>				
      <property name="GameName" 				value="Razorsworld"/>			
      <property name="GameDifficulty" 			value="2"/>  				
      <property name="GameMode"					value="GameModeSurvival"/>	
    
      <property name="ZombiesRun"				value="0" />				
      <property name="ZombieMove"				value="0" />				
      <property name="ZombieMoveNight"			value="2" />				
      <property name="ZombieFeralMove"			value="3" />				
      <property name="ZombieBMMove"				value="2" />				
      <property name="BuildCreate"				value="false" />			
      <property name="DayNightLength"			value="60" />				
      <property name="DayLightLength"			value="18" />				
      <property name="PlayerKillingMode"		value="3" />				
      <property name="PersistentPlayerProfiles"	value="false" />			
    
      <property name="PlayerSafeZoneLevel"	    value="5" />				
      <property name="PlayerSafeZoneHours"	    value="5" />				
    
      <property name="ControlPanelEnabled"	 	value="true"/>				
      <property name="ControlPanelPort" 		value="8080"/>				
      <property name="ControlPanelPassword" 	value="zed"/>			
    
      <property name="TelnetEnabled"	 		value="true"/>				
      <property name="TelnetPort" 				value="8081"/>				
      <property name="TelnetPassword" 			value=""/>					
      <property name="TelnetFailedLoginLimit"	value="10"/>				
      <property name="TelnetFailedLoginsBlocktime"	value="10"/>			
    
      <property name="TerminalWindowEnabled"    value="false"/>              
    
      <property name="AdminFileName"			value="serveradmin.xml"/>	
    
      <property name="DropOnDeath"				value="2" />				
      <property name="DropOnQuit"				value="0" />				
    
      <property name="BloodMoonEnemyCount"		value="8" />				
      <property name="EnemySpawnMode"			value="true" />				
      <property name="EnemyDifficulty"			value="0" />				
    
      <property name="BlockDurabilityModifier" 	value="100" /> 				
    
      <property name="LootAbundance" 			value="100" /> 				
      <property name="LootRespawnDays"		 	value="15" /> 				
    
      <property name="LandClaimSize" 						value="41"/>	
      <property name="LandClaimDeadZone" 					value="30"/>	
      <property name="LandClaimExpiryTime" 					value="3"/>		
      <property name="LandClaimDecayMode" 					value="0"/>		
      <property name="LandClaimOnlineDurabilityModifier" 	value="4"/>		
      <property name="LandClaimOfflineDurabilityModifier" 	value="4"/>		
    
      <property name="PartySharedKillRange" 				value="100"/>	
      <property name="AirDropFrequency"						value="72"/>    
      <property name="AirDropMarker"						value="true"/>	
      <property name="MaxSpawnedZombies"					value="60"/>

  2. #2
    Hunter
    Join Date
    Jan 2019
    Posts
    113
    Rep Power
    0
    I would move the folder back where it originally was for starters. I've had issues before where it I did this and it wasn't correctly pointing to the serveradmin.xml. Make sure port forwarding is correctly setup for port 26900 and make sure you change your passwords later. You also have no telnet password setup either. When in doubt always check the log file. I run mine on linux so not exactly sure where it's located in Windows.

  3. #3
    Scavenger
    Join Date
    Nov 2018
    Location
    Eagle, MI USA
    Posts
    34
    Rep Power
    0
    You have to give the server a seed name: Change from
    <property name="WorldGenSeed" value=""/>

    ... to something like:
    <property name="WorldGenSeed" value="RZRWorld"/>

  4. #4
    Refugee
    Join Date
    Jan 2020
    Posts
    1
    Rep Power
    0
    I also have a question, im trying to create a RWG and it never makes it past generating socket data. below are my setting and i could really use some help thanks. I've let it sit and load for over 14 hours and nothing. I removed all the extra explination stuff to make the settings easier to read. Ive also tried loading these settings on two different computer and got the same resault.

    <?xml version="1.0"?>
    <ServerSettings>
    <!-- GENERAL SERVER SETTINGS -->

    <!-- Server representation -->
    <property name="ServerName" value="Chase Server"/>
    <property name="ServerDescription" value="A 7 Days to Die server"/>
    <property name="ServerWebsiteURL" value=""/>
    <property name="ServerPassword" value="jeffc"/>
    <property name="ServerLoginConfirmationText" value="" />

    <!-- Networking -->
    <property name="ServerPort" value="26900"/>
    <property name="ServerVisibility" value="2"/>
    <property name="ServerDisabledNetworkProtocols" value="SteamNetworking"/>
    <property name="ServerMaxWorldTransferSpeedKiBs" value="1300"/>

    <!-- Slots -->
    <property name="ServerMaxPlayerCount" value="8"/>
    <property name="ServerReservedSlots" value="0"/>
    <property name="ServerReservedSlotsPermission" value="100"/>
    <property name="ServerAdminSlots" value="0"/>
    <property name="ServerAdminSlotsPermission" value="0"/>

    <!-- Admin interfaces -->
    <property name="ControlPanelEnabled" value="true"/>
    <property name="ControlPanelPort" value="8080"/>
    <property name="ControlPanelPassword" value=""/>

    <property name="TelnetEnabled" value="true"/>
    <property name="TelnetPort" value="8081"/>
    <property name="TelnetPassword" value=""/>
    <property name="TelnetFailedLoginLimit" value="10"/>
    <property name="TelnetFailedLoginsBlocktime" value="10"/>
    <property name="TerminalWindowEnabled" value="true"/>

    <!-- Folder and file locations -->
    <property name="AdminFileName" value="serveradmin.xml"/>
    <!-- <property name="UserDataFolder" value="absolute path" /> -->
    <!-- <property name="SaveGameFolder" value="absolute path" /> -->

    <!-- Other technical settings -->
    <property name="EACEnabled" value="true"/>
    <property name="HideCommandExecutionLog" value="0"/>
    <property name="MaxUncoveredMapChunksPerPlayer" value="131072"/>
    <property name="PersistentPlayerProfiles" value="false" />

    <!-- GAMEPLAY -->

    <!-- World -->
    <property name="GameWorld" value="RWG"/>
    <property name="WorldGenSeed" value="breezyonion"/>
    <property name="WorldGenSize" value="16384"/>
    <property name="GameName" value="Chase Game"/>
    <property name="GameMode" value="GameModeSurvival"/>

    <!-- Difficulty -->
    <property name="GameDifficulty" value="2"/>
    <property name="BlockDamagePlayer" value="100" />
    <property name="BlockDamageAI" value="100" />
    <property name="BlockDamageAIBM" value="100" />
    <property name="XPMultiplier" value="100" />
    <property name="PlayerSafeZoneLevel" value="5" />
    <property name="PlayerSafeZoneHours" value="5" />

    <!-- -->
    <property name="BuildCreate" value="false" />
    <property name="DayNightLength" value="120" />
    <property name="DayLightLength" value="18" />
    <property name="DropOnDeath" value="3" />
    <property name="DropOnQuit" value="0" />
    <property name="BedrollDeadZoneSize" value="15" />
    <property name="BedrollExpiryTime" value="45" />

    <!-- Performance related -->
    <property name="MaxSpawnedZombies" value="60" />
    <property name="MaxSpawnedAnimals" value="100" />
    <property name="ServerMaxAllowedViewDistance" value="12" />

    <!-- Zombie settings -->
    <property name="EnemySpawnMode" value="true" />
    <property name="EnemyDifficulty" value="0" />
    <property name="ZombieMove" value="0" />
    <property name="ZombieMoveNight" value="0" />
    <property name="ZombieFeralMove" value="0" />
    <property name="ZombieBMMove" value="0" />
    <property name="BloodMoonFrequency" value="7" />
    <property name="BloodMoonRange" value="0" />
    <property name="BloodMoonWarning" value="8" />
    <property name="BloodMoonEnemyCount" value="8" />

    <!-- Loot -->
    <property name="LootAbundance" value="150" />
    <property name="LootRespawnDays" value="15" />
    <property name="AirDropFrequency" value="24"/>
    <property name="AirDropMarker" value="true"/>

    <!-- Multiplayer -->
    <property name="PartySharedKillRange" value="10000"/>
    <property name="PlayerKillingMode" value="2" />

    <!-- Land claim options -->
    <property name="LandClaimCount" value="1"/>
    <property name="LandClaimSize" value="41"/>
    <property name="LandClaimDeadZone" value="30"/>
    <property name="LandClaimExpiryTime" value="7"/>
    <property name="LandClaimDecayMode" value="0"/>
    <property name="LandClaimOnlineDurabilityModifier" value="4"/>
    <property name="LandClaimOfflineDurabilityModifier" value="4"/>


    </ServerSettings>

  5. #5
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    9,169
    Rep Power
    1
    Quote Originally Posted by jchase222 View Post
    I also have a question, im trying to create a RWG and it never makes it past generating socket data. below are my setting and i could really use some help thanks. I've let it sit and load for over 14 hours and nothing. I removed all the extra explination stuff to make the settings easier to read. Ive also tried loading these settings on two different computer and got the same resault.
    ...
    "WorldGenSize" value="16384"

    That's going to take you a really long time if you don't use Nitrogen.

    With a high-end dedicated server using 24 CPU cores and 68GB RAM it will take about 9 hours.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •