Page 1 of 11 123 ... LastLast
Results 1 to 15 of 152

Thread: Alpha 17.2 B27 bug reporting thread

  1. #1
    Fun Pimps Staff The Fun Pimp's Avatar
    Join Date
    Nov 2013
    Posts
    617
    Rep Power
    2

    Alpha 17.2 B27 bug reporting thread

    We’ve just released Alpha 17.2 B27 with many fixes, changes and some great new game options.

    Official Release Notes


    BUG REPORTING FORM

    Please use this form to report bugs, Testers will then respond, if the form is not used we will assume you are just chatting to each other

    Summary: (short description of bug)
    Version:
    Platform: (PC or Mac)
    OS/Version: Windows/Linux/mac
    Game mode, mp host/mp client/sp /client on dedi (RWG or NAV)

    Did you wipe old saves? (yes/No)
    Did you start a new game? (Yes/No)
    Did you validate your files? (Yes/No)
    Are you using any mods? (yes/No)
    EAC on or off ?

    Status: NEW

    Bug Description:

    Reproduce steps:

    Press F1 to open the console, then type dbs
    This will open a panel in game for you to type the bug in.
    once done click ok
    there will then be a SCREENSHOTS folder in the main 7 days folder.

    1)
    2)
    3)

    Actual result: (description of what is occurring)

    Expected result: (what you expect to occur)

    [Attach bug screenshot and output log for ALL bugs please]

    Pastebin how to video, https://www.youtube.com/watch?v=CpTJMIJ1XnQ
    Pastebin link , https://pastebin.com/7wLyjkTT



    your output log files are in C /steamLibrary/steamapps/common/7Daystodie/7daystodiedata/ you will find a list of ol logs, the last one being the most recent.

    also when taking a screen shot you can use the debug info, go into dm mode ( Type dm in the console ) Type dm to turn it off again
    Press F3, that will bring up the debug overlay, you will need to press f3 twice to close it.
    If you use the f3 feature no need for cords in the screen shot as they are in that info.



    For serverowners:

    Added: serverconfig property "UserDataFolder" to specify where all generated data on the server is stored, including generated RWG worlds
    Added: new properties “XPMultiplier”, “BlockDamagePlayer”, “BlockDamageAI”, “BlockDamageAIBM”
    Removed: old properties “BlockDurabilityModifier”, “ZombiesRun”
    Changed: TerminalWindowEnabled default is set to true

    Please be sure you are using these properties in your serverconfig.xml:

    <property name="BloodMoonFrequency" value="7" /> <!-- What frequency (in days) should a blood moon take place -->
    <property name="BloodMoonRange" value="0" /> <!-- How many days can the actual blood moon day randomly deviate from the above setting. Setting this to 0 makes blood moons happen exactly each Nth day as specified in BloodMoonFrequency -->
    <property name="BloodMoonWarning" value="8" /> <!-- The Hour number that the red day number begins on a blood moon day. Setting this to -1 makes the red never show. -->
    <property name="LandClaimCount" value="1"/> <!-- Maximum allowed land claims per player. -->
    <property name="BlockDamagePlayer" value="25" /> <!-- How much damage do players to blocks (percentage in whole numbers) -->
    <property name="BlockDamageAI" value="100" /> <!-- How much damage do AIs to blocks (percentage in whole numbers) -->
    <property name="BlockDamageAIBM" value="100" /> <!-- How much damage do AIs during blood moons to blocks (percentage in whole numbers) -->
    <property name="XPMultiplier" value="100" /> <!-- XP gain multiplier (percentage in whole numbers) -->


    Known Issues

    • RWG Generation is not in its final state. Work is currently being done to improve roads, towns, terrain, generation speed, and world size. These changes will come in a later A17.x patch once they are ready.
    • In some scenarios double swing may still occur
    • Tool damage localization is different than actual value
    • RWG: Floating POIs (Minimal occurrence now)
    • Trader Jen has a deep voice
    • Trader Rekt is nicer than usual
    • Charismatic Nature is still in need of improvement, buff works for 5 seconds and 5 seconds it does not
    • Scrapping items in crafting queue while re-logging may go lost
    • Crafting speed bonus and mod slots do not properly apply to workstations after being closed
    • Clipping into blocks to see through terrain
    • Shotgun driver loses sound on 44 after a while
    • Workstation tools do not refresh the recipe list when the tools are installed
    • Can use torch and flaming arrows as light underwater
    • RWG preview tool localization
    • Firearms do a duplicate reload animation after reloading while zoomed (locked in zoom)
    • Mining helmet light doesn’t show for other players
    • Client molotovs thrown down from an edge not working as good as Host
    • Hatches don’t always open on the first try
    • Player model jumps forward of the player camera when accessing an auto turret inventory
    • Turrets will not target self when set to do so
    • Player can consume any consumable while mounted in vehicle but will not get the buff/debuff
    • Resolution does not always save when >1080p options are available
    • Burning shaft mod flame effect can transfer to other items on the toolbelt
    • Healing other players with RMB doesn’t work
    • Self medicated is not working properly. Not being able to purchase perk is intended.
    • Crashes on Mac for a possible workaround, please look at https://7daystodie.com/forums/showth...106#post914106
    • If connection to server fails, try removing steamnetworking as a disabled function from the serverconfig.xml
    • White lines may occur on imposter POIs
    • Some Linux users experience problems
    • When using REALLY excessive amounts of resources they may vanish in cement mixer’s crafting queue
    • Chunk corruption errors
    • Showbounds for landclaims shows a box instead of it actual infinite size for y
    • Illness buff may not properly run out
    • Nightvision goggles are not very effective
    Last edited by Hated; 02-27-2019 at 11:12 PM.

  2. #2
    Tracker
    Join Date
    Jun 2017
    Posts
    206
    Rep Power
    0
    Summary: When aiming down the sights, if you switch to a different toolbelt item, the camera moves back into your head and shows part of your head and a weird view of your arms and you holding other items. AK47 + reflex sight
    Spoiler: 


    Version: a17.2
    Platform: PC
    OS/Version: Windows
    Game mode: SP

    Did you wipe old saves? Yes
    Did you start a new game? Yes
    Did you validate your files? Yes
    Are you using any mods? No
    EAC on or off ? On

    Status: NEW

    Bug Description:

    Reproduce steps:



    1) ADS (aim down the sights) with a weapon.
    2) Don't release the ADS and switch to a different toolbelt item.
    3)

    Actual result: (description of what is occurring) When aiming down the sights, if you switch to a different toolbelt item, the camera moves back into your head and shows part of your head and a weird view of your arms and you holding other items.

    Expected result: (what you expect to occur) Camera should revert back to the non-ADS position when changing items

    [Attach bug screenshot and output log for ALL bugs please]

    Video demo here: https://streamable.com/bg7we

    This happens both when using Hold ADS or Toggle ADS.


    ---------

    Also, I still don't see "No FOV Slider" or "Micro-stuttering" in the known issues. I'd also like to encourage devs to put giving us a playable RWG as the first and only priority right now, and to not worry about fixing things like female hair color until we get a working RWG.


    ***************************************

    (edit added comment by QA Tester-unholyjoe)

    issue with aiming is known and reported

    Thanks

    ***************************************
    Last edited by unholyjoe; 02-28-2019 at 01:32 AM.

  3. #3
    Zombie Hunter
    Join Date
    Dec 2016
    Posts
    461
    Rep Power
    1
    Summary: stuck at starting game
    Spoiler: 

    Version: 17.2 b27 stable
    Game mode: MP Dedi - Client - RWG

    Did you wipe old saves? y
    Did you start a new game? y
    Did you validate your files? y
    Are you using any mods? n
    EAC on or off ? On

    Status: NEW

    Bug Description: We wiped and started two fresh maps for our servers. No one is able to connect. They get hung up at "starting Game" we can hear game sounds, but the game wont clear the starting game screen. We have tried teleporting and death. Death renders the bloody screen and we see our bodies, but the starting game window is still there.

    We noticed errors with "character in wrong position" and loading in at 0.0, 0.0, 0.0.

    https://pastebin.com/dLZq0mVN



    --- update ---

    We turned off some of the new features and it seems to work now.

    ***************************************

    (edit added comment by QA Tester-unholyjoe)

    glad to see you fixed it, but what features did you have to turn off? this will only help us in reporting/tuning/fixing issues if we had some good info.

    thanks

    ***************************************
    Last edited by unholyjoe; 02-28-2019 at 02:32 PM.

  4. #4
    Hunter Aribo's Avatar
    Join Date
    Apr 2016
    Location
    North East UK
    Posts
    144
    Rep Power
    0
    TFP can you please post a full new serverconfig.xml thanks

    https://pastebin.com/sjPqWk9J

    Enjoy !
    -Hated
    Last edited by Hated; 02-28-2019 at 03:00 PM.

  5. #5
    Refugee MNBear82's Avatar
    Join Date
    Feb 2019
    Location
    West Hartford CT US
    Posts
    6
    Rep Power
    0
    Does this mean that Alpha 17.2 b27 is now stable?

    Yup !
    -Hated
    Last edited by Hated; 02-28-2019 at 02:58 PM.

  6. #6
    Colony Founder Lonestarcanuck's Avatar
    Join Date
    May 2014
    Location
    Texas
    Posts
    2,093
    Rep Power
    1
    Hmmm. can I file a bug that no one is reporting bugs and its been 22 hours?

    also an injunction to stop nerfing XP with selling to traders

  7. #7
    Refugee
    Join Date
    Dec 2018
    Posts
    2
    Rep Power
    0
    Summary: Zombies run partially during the day
    Version: 17.2 B27
    Plattform: PC
    OS / Version: Windows
    Map: RWG

  8. #8
    Refugee
    Join Date
    Dec 2018
    Posts
    2
    Rep Power
    0
    Summary: Control of the character stops occasionally and you stand there motionless
    Version: 17.1 and 17.2 B27
    Plattform: PC
    OS / Version: Windows
    Map: RWG

  9. #9
    Refugee
    Join Date
    Dec 2018
    Posts
    7
    Rep Power
    0
    We just got forced to update to 17.2 and playing on a dedicated server.
    Spoiler: 


    So, 7DTD crew.

    After updating, we (two players) were in transit to a trader (waste land) in vehicles (gyro and motorcycle) when the server kicked us outside of Gravestown and we lost both vehicles, with all of our gear.

    Nice job.

    And now you are going to ask for all of the logs, blah blah blah.

    FFS, folks the game should not blow up mid stream, leave you standing in the middle of BFE and have your transports gone.


    WTF?


    When I get done fuming, I may post logs. This is bull♥♥♥♥.

    - - - Updated - - -

    So, 7DTD crew.

    we just got forced to update to 17.2 and playing on a dedicated server.

    After updating, we (two players) were in transit to a trader (waste land) in vehicles (gyro and motorcycle) when the server kicked us outside of Gravestown and we lost both vehicles, with all of our gear.

    Nice job.

    And now you are going to ask for all of the logs, blah blah blah.

    FFS, folks the game should not blow up mid stream, leave you standing in the middle of BFE and have your transports gone.


    WTF?


    When I get done fuming, I may post logs. This is bull♥♥♥♥.


    Sorry, we do not start the updates remotely, whoever operates the server must have updated.

    If you want to avoid the updating you can opt into the beta tab for the latest stable build in this scenario "alpha17.2 - Alpha 17.2 Stable"
    -Hated
    Last edited by Hated; 03-01-2019 at 12:53 AM.

  10. #10
    Refugee
    Join Date
    Dec 2018
    Posts
    7
    Rep Power
    0
    Ok, game has a SERIOUS glitch

    my friend on my server stated they just got back on their bike mid stream in the game.

    I am running around Gravestown fighting my way out when BOOM, I am back on my Gryo, crash into a building and get jumped.


    BIG GAME GLITCH.


    Collecting logs now

  11. #11
    Refugee
    Join Date
    Dec 2018
    Posts
    7
    Rep Power
    0
    Summary: Players lose vehicles after server kicks them, and then suddenly re-emerge on vehicles after 5-10 of real time play
    Version: 17.2 B27
    Platform: PC
    OS/Version: Windows 8 and 10
    Game mode: dedicated

    Map: Navesgane large map 1600

    Status: NEW

    Did you wipe old saves? No
    Did you start a new game? No
    Did you validate your files? Yes
    Are you using any mods? No
    EAC on or off ? ON

    Bug Description:

    Reproduce steps:
    When you are moving across the game in a vehicle and the game crashes/kicks you out. you re-appear without a vehicle and the vehicle is not on the map.

    After 5-10 minutes, you will suddenly re-appear on your vehicle.

    EXPECTED RESULT: you re-appear near your vehicle

    Bug Description:

    Reproduce steps: Need to get the server to kick you when you are on a vehicle

    LOGS: https://pastebin.com/wZpwXxza


    PLEASE PING ME IF YOU NEED MORE DATA POINTS

  12. #12
    Refugee
    Join Date
    Dec 2018
    Posts
    7
    Rep Power
    0
    The 7DTD client updated to 17.2 Stable, Hated.

    I had to force the server, that I rent, to update from 17.2 to 17.2.

    Net-net is the issue is related to the 17.2 stable version.

    Sorry, we do not start the updates remotely, whoever operates the server must have updated.

    If you want to avoid the updating you can opt into the beta tab for the latest stable build in this scenario "alpha17.2 - Alpha 17.2 Stable"
    -Hated
    [/QUOTE]

  13. #13
    Scavenger morggin's Avatar
    Join Date
    Nov 2018
    Location
    Tacoma, WA
    Posts
    38
    Rep Power
    0
    Summary: Bug in RWG
    Version: 17.2 b27
    Platform: PC
    OS/Version: Linux Dedicated server
    Game mode, dedi RWG


    2019-02-28T19:57:39 618.706 INF WorldGenerator:Generating Biome Data
    Biome Generator Missed 379855 Sockets

    (Filename: ./Runtime/Export/Debug.bindings.h Line: 43)

    Dosn't seem to effect RWG as it continues after 4 minutes 11 seconds.

  14. #14
    Refugee
    Join Date
    Feb 2019
    Location
    Atlanta, GA
    Posts
    6
    Rep Power
    0
    Summary: Parts of buildings are gone after update
    Version: 17.2 stable (upgraded from 17.1 stable)
    Platform: PC
    OS/Version: Windows
    Game mode: NAV

    See attached screenshots

    Before: base.jpg
    After: missing_base.jpg

  15. #15
    Zombie Hunter
    Join Date
    Dec 2016
    Posts
    461
    Rep Power
    1
    Quote Originally Posted by Donovan522 View Post
    Summary: Parts of buildings are gone after update
    Version: 17.2 stable (upgraded from 17.1 stable)
    Platform: PC
    OS/Version: Windows
    Game mode: NAV

    See attached screenshots

    Before: base.jpg
    After: missing_base.jpg
    We were having this issue on all 3 of our servers, have no idea what was causing it. So we decided to wipe and start fresh for 17.2 incase the problem was some sort of bug lingering from a previous build.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •