Page 10 of 72 FirstFirst ... 891011122060 ... LastLast
Results 136 to 150 of 1077

Thread: Native Linux server (with management scripts)

  1. #136
    Refugee
    Join Date
    Jul 2014
    Posts
    7
    Rep Power
    0
    Well, from what I experienced it seems to work the same with no changes. Running multiple instances may not work, but I don't know if it did or did not work before.

    EDIT: Oh, and the update to 8.7 may nerf your save game file so be sure to back it up first!
    Last edited by SuspiciouslyAbsent; 07-10-2014 at 03:51 AM.

  2. #137
    Refugee
    Join Date
    Jul 2014
    Location
    Tokyo Infected Area
    Posts
    4
    Rep Power
    0
    I ran the script
    /usr/local/bin/7dtd.sh instances updateengine
    then created new game instance using new config template, played several minutes and it seems just fine.

    However, since I'm new to 7dtd itself, I don't know whether the linux_files including "7DaysToDie.x86 engine" have to be updated or not.
    As far as I know, the updateengine option updates only the game itself via steamcmd.
    So, I re-downloaded and checked the linux_files that Alloc provided. Their timestamp are still 2 weeks ago, so there's no change at the moment.
    Does anyone know where to get information about 7DaysToDie.x86? Is that the official one? If so, where can I get the latest build?

    Anyway, this thread is very helpful. Thanks!

  3. #138
    Reconstructionist Koolio's Avatar
    Join Date
    Nov 2013
    Location
    http://7dtd.tk
    Posts
    534
    Rep Power
    0
    Well it does still work after updating the engine, but I guess it will need a script update to configure some of the newer 8.7 server stuff (though not much sadly)

  4. #139
    Hunter
    Join Date
    Mar 2014
    Posts
    122
    Rep Power
    0
    Yes there are some changes needed. Keep calm Alloc will release them as fast as possible for him.
    In general you can run the server scripts without any problems.

  5. #140
    Fun Pimps Staff Alloc's Avatar
    Join Date
    Oct 2013
    Location
    Germany - Darmstadt
    Posts
    3,143
    Rep Power
    1
    Regarding Alpha 8.7
    The current version of the scripts will work with 8.7. Only things not working right now: Log parsing to get events like player (dis)connect logged etc. Also the two new config options are obviously not yet included in the instance editor. Will release an update for this within the next 12 hours.

    There's no need to update anything else besides the game, the Linux specific files only change when TFP switch to a newer Unity version.


    Quote Originally Posted by SuspiciouslyAbsent View Post
    Well, from what I experienced it seems to work the same with no changes. Running multiple instances may not work, but I don't know if it did or did not work before.
    Did you test it and it did *not* work? Should work, so that would have to be checked


    Quote Originally Posted by kakusha View Post
    Does anyone know where to get information about 7DaysToDie.x86? Is that the official one? If so, where can I get the latest build?
    There's no "official" Linux binaries yet. Those are all provided by me so far and the latest is within the tar-archive linux_files.tar.gz, but that won't update as long as I do not announce so


    Quote Originally Posted by Koolio View Post
    Well it does still work after updating the engine, but I guess it will need a script update to configure some of the newer 8.7 server stuff (though not much sadly)
    Only things changed AFAIK are the two new options: MaxSpawnedZombies, VACEnabled. Anything else changed?



    New dedicated server build
    I will also test if the new dedi build runs fine with the current stuff and then switch to using that one. That might take one or two days more though.


    Regards,
    Chris

  6. #141
    Reconstructionist Koolio's Avatar
    Join Date
    Nov 2013
    Location
    http://7dtd.tk
    Posts
    534
    Rep Power
    0
    Only things changed AFAIK are the two new options: MaxSpawnedZombies, VACEnabled. Anything else changed?
    Didn't seem like a whole lot added for servers

    New dedicated server build
    I will also test if the new dedi build runs fine with the current stuff and then switch to using that one. That might take one or two days more though.
    Maybe they should just hire you to make the dedicated linux builds seems like the entire area gets ignored or they don't have enough developers to work on more areas of the game.

  7. #142
    Refugee
    Join Date
    Jul 2014
    Location
    Tokyo Infected Area
    Posts
    4
    Rep Power
    0
    Thank you all for answering such hasty-successive questions. Now that I grasped some part of the situation.
    Knowing that, I want to thank you again, Alloc!
    ...well, I'd hosted a certain zombie MOD server, so I'm accustomed to waiting(nicely) for the devs!

  8. #143
    Hunter
    Join Date
    Mar 2014
    Posts
    122
    Rep Power
    0
    Quote Originally Posted by Koolio View Post
    Maybe they should just hire you to make the dedicated linux builds seems like the entire area gets ignored or they don't have enough developers to work on more areas of the game.
    Finally there is no much difference between the Windows and Linux dedicated server. Just the binary is different, which is delievered by Unity.
    I think there are issues with the dependencies.

  9. #144
    Fun Pimps Staff Alloc's Avatar
    Join Date
    Oct 2013
    Location
    Germany - Darmstadt
    Posts
    3,143
    Rep Power
    1
    Just uploaded v.25. See the release notes for more info on changes

  10. #145
    Survivor
    Join Date
    Nov 2013
    Posts
    59
    Rep Power
    0
    i've been a day-one user of your scripts and initially only used parts of them in my own linux setup.

    with 8.7 i finally took the plunge and did a reinstall via the full wiki instructions. and i'm very glad i did! it's seems very polished and well put together: nice countdown when i shutdown, clean XML reader which outputs sane files, self explanatory folder names,... so thanks for all that! i appreciate it.

  11. #146
    Survivor
    Join Date
    Nov 2013
    Posts
    59
    Rep Power
    0
    i get this error on shutdown (but shutdown still works):

    # /etc/init.d/7dtd.sh stop
    Stopping all instances:
    nekapuzer:
    Trying to gracefully shutdown...
    Waiting for server to shut down...
    1/5
    2/5
    3/5
    /usr/local/lib/7dtd/commands/stop.sh: line 52: setAllPlayersOffline: command not found
    Done
    i see that this function is defined in playerlog.sh but i don't see it "imported" (...i'm a bash noob) in stop.sh

  12. #147
    Fun Pimps Staff Alloc's Avatar
    Join Date
    Oct 2013
    Location
    Germany - Darmstadt
    Posts
    3,143
    Rep Power
    1
    Hi smono,

    always happy to hear when people like it

    Quote Originally Posted by smono View Post
    i get this error on shutdown (but shutdown still works):
    ...
    i see that this function is defined in playerlog.sh but i don't see it "imported" (...i'm a bash noob) in stop.sh
    Thanks for reporting, missed that one when working on v.25. In v.26 this error is fixed (though it's only cosmetical, it does not do anything bad or wrong ).

    Regards,
    Chris

  13. #148
    Scavenger
    Join Date
    Jul 2014
    Posts
    57
    Rep Power
    0
    First of all: Great work on these server management scripts and Linux support!

    Is there any news on when the players.xml logging (f.ex. online-status) will be functional again?
    Also, my hooks no longer seem to work since upgrading to 8.7, anyone else running into this problem?

  14. #149
    Fun Pimps Staff Alloc's Avatar
    Join Date
    Oct 2013
    Location
    Germany - Darmstadt
    Posts
    3,143
    Rep Power
    1
    Quote Originally Posted by Isalof View Post
    Is there any news on when the players.xml logging (f.ex. online-status) will be functional again?
    Also, my hooks no longer seem to work since upgrading to 8.7, anyone else running into this problem?
    Quote Originally Posted by Alloc View Post
    Just uploaded v.25. See the release notes for more info on changes
    So, since v.25 logging is working again
    Should also fix your hooks, if not we have to check what's causing this for you.

  15. #150
    Scavenger
    Join Date
    Jul 2014
    Posts
    57
    Rep Power
    0
    Oh, well.. something isnt right then It was working before 8.7 though.
    I created the hooks folder and placed a script for player-connection which I then marked executable (/home/sdtd/hooks/playerConnect/playerConMsg.sh)
    #!/bin/sh
    . /usr/local/lib/7dtd/common.sh
    telnetCommand $1 "say Welcome $4!"
    Regarding log output, I just created a new instance and even after joining the resulting logfile "2014-07-12_09-44-16_output.log" only contains one line (Starting instance).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •