Results 1 to 5 of 5

Thread: Non game mouse issue

  1. #1
    Hood Ornament Gamida's Avatar
    Join Date
    May 2015
    Location
    The Rock
    Posts
    4,020
    Rep Power
    1

    Non game mouse issue

    Hey

    It seems my mouse is glitching out. Sometimes my left mouse button doesn't register clicks. Sometimes I have trouble dragging and dropping. I will grab something and before I can move it to where I want the button suddenly decides it is not clicked anymore and lets go. It seems to only be the left mouse button. I have tried a different usb port and have even tried a different mouse. Same thing.
    I looked it up and it has been said sometimes reinstalling the driver will fix it but I tried and that didn't seem to help. I looked for a newer driver (one I have says it's from 2006. Maybe it is latest one) but couldn't find one out there without having to use some third party driver utility.
    I also ran Malwarebytes Antimalware and didn't see any problems and my antivirus hasn't noticed anything.
    Getting annoying now as when I move items in my inv in game I keep dropping them.

  2. #2
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    8,040
    Rep Power
    1
    Open the game launcher, and tick the option for "Use native input". Could be a conflict with the games input interface, and the software for your mouse.

  3. #3
    Hood Ornament Gamida's Avatar
    Join Date
    May 2015
    Location
    The Rock
    Posts
    4,020
    Rep Power
    1
    I have already tried that for the game but this is happening in everything, not just the game.
    I have tried a bunch of stuff from online. Reinstall mouse driver, run sfc in power shell, hard boot, and some other stuff but nothing seems to be working. It seems everything else on computer is working fine except my left mouse click. Am going to try a third mouse. This one is new out of box that I had bought earlier with a keyboard combo. Will let you know what happens.

    Edit:Ok, it may have been the mouse after all. New mouse seems to be working fine.
    Thing is I had tried a second mouse but that also had same problem.
    The 2 mice that did not work were corded and the new one that works is wireless. Not sure if that has something to do with it. I thought my usb ports were screwed up but the dongle is in the usb port I had the corded mice in so go figure.
    Thanks SilenThunder for the input.
    Last edited by Gamida; 05-11-2019 at 05:38 PM.

  4. #4
    Ranger
    Join Date
    Mar 2017
    Posts
    317
    Rep Power
    0
    got a controller plugged in?

  5. #5
    Hood Ornament Gamida's Avatar
    Join Date
    May 2015
    Location
    The Rock
    Posts
    4,020
    Rep Power
    1
    Quote Originally Posted by Data View Post
    got a controller plugged in?
    Not anymore. Had one plugged in a couple months or more ago but not since.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •