Results 1 to 2 of 2

Thread: Private server modding

  1. #1
    Refugee Zi0NM4N's Avatar
    Join Date
    Aug 2019
    Posts
    1
    Rep Power
    0

    Question Private server modding

    Hello i'm playing 7dtd for a little while now I am trying to setup a server on my linux home server (ryzen 7 2700x with 64gb ram running on debian 10 x86_64 on fiber optic internet connection so this should run smoothly)
    But I manage to launch the server but i'm unable to add mods I tried to copy my Mods game folder but when I launch the server none are loaded.
    I checked the user who launch process is the owner of the folder I tried to chmod in 777 just in case but nothing.
    I tried to rename the folder mods same thing.
    Is there an extra argument to add to the server launcher shellscript or an extra command to load it in admin console?
    Or maybe an extra line to add in the serverconfig.xml file?
    I'm completely stuck on this one .
    I hope it is the right section of the forum for this kind of questions .

  2. #2
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    8,467
    Rep Power
    1
    If the mods folder is in the correct location, it should load automatically.

    For example...

    My server engine path...
    //home/beta/engine

    Mods folder path...
    //home/beta/engine/Mods

    And remember, since this is Linux, it's case-sensitive. If you have //home/beta/engine/mods it won't work.

    Aside from that, I'd need more information on your configuration and possibly logs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •