Results 1 to 8 of 8

Thread: Cant stop walking when releasing key Alpha 17 on Linux

  1. #1
    Refugee
    Join Date
    Sep 2019
    Posts
    4
    Rep Power
    0

    Cant stop walking when releasing key Alpha 17 on Linux

    Summary: Cant stop walking when releasing key
    Version: 17.0 - 17.4
    Platform: PC
    OS/Version: Linux Ubuntu 19.04
    Game mode, SP

    Did you wipe old saves? yes
    Did you start a new game? Yes
    Did you validate your files? Yes
    Are you using any mods? No
    EAC on or off ? On

    Status: NEW

    Bug Description: While walking any direction in 7 Days to die when I release the key (WASD) my character continues walking for a while after wards. I created a video for you to fully understand. With all the stats of my PC. This makes the game unplayable. However if I drop back to 16.4 it works fine.

    See Video
    https://www.youtube.com/embed/M7ZEseuMQzs


    Reproduce steps:


    1) Install 7 Days to die 17.4 on Ubuntu 19.04
    2) Try walking a good distance holding down the action key
    3) release and wait to stop (make sure you have a full beer)

    Actual result: I stopped about 4 minutes later (and I need another beer)

    Expected result: To Stop when I release the key.


    Pastebin link , https://pastebin.com/ZSAETWw0

  2. #2
    Refugee
    Join Date
    Sep 2019
    Posts
    4
    Rep Power
    0
    Nevermind I found the solution you have to turn off keyboard repeat using the "xset r off" command in the linux terminal.

  3. #3
    Nomad Beelzybub's Avatar
    Join Date
    Dec 2015
    Posts
    382
    Rep Power
    1
    Nicely done with both the bug report and the solution. Your framerate is really low, you should be able to do better with that system. I get about 30-40 with a worse machine running Mint 18.

  4. #4
    Colony Founder meganoth's Avatar
    Join Date
    Mar 2017
    Posts
    2,704
    Rep Power
    1
    Excellent detective work. I can confirm the solution works:

    I used my older PC since low FPS aka high CPU load has a big influence on the severity of this bug. Spawned 60 arlenes and tried it with and without "xset -r 25" (25 being the keycode of "W" on linux.

    Result: Without key repeat I could stop almost immediately, with key repeat I kept running a few meters until stopping.

  5. #5
    Refugee
    Join Date
    Oct 2017
    Posts
    25
    Rep Power
    0
    hi the commande "xset r off" not existe in my linux terminal, im in pop-os .

  6. #6
    Colony Founder meganoth's Avatar
    Join Date
    Mar 2017
    Posts
    2,704
    Rep Power
    1
    pop-os seems to be derived from ubuntu. I checked, "xset" is part of ubuntu 18.04 as well as 19.04.

    What error message do you get when you try to execute the line?

  7. #7
    Refugee
    Join Date
    Oct 2017
    Posts
    25
    Rep Power
    0
    Last edited by Tuxette; 2 Weeks Ago at 12:34 PM.

  8. #8
    Colony Founder meganoth's Avatar
    Join Date
    Mar 2017
    Posts
    2,704
    Rep Power
    1
    Remove the quotation marks / les guillemets.

    With quotation marks the terminal is searching for the command xset_r_off without parameters. Instead it should look for the command xset with the parameters r and off

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •