Results 1 to 3 of 3

Thread: Personal dedicated server crash caused major problems.

  1. #1
    Refugee
    Join Date
    Sep 2019
    Posts
    1
    Rep Power
    0

    Unhappy Personal dedicated server crash caused major problems.

    Currently we (close friends and I) are working on starting a new server, the one that crashed was only a few hours old. But I'd still like to know how to fix this in the future.


    Started a new server with the 7DTD dedicated server system provided by Steam, and about 5 hours into it's life, my buddy's home server crashed (Fu** you, windows server system, we're going to linux) and when we started the server up again, we had to redownload the map and a few things happened:

    1: No trees. anywhere at all.
    2: Reduced mob spawning. nearly every prefab has no zombies inside
    3: when the map is opened, it is all grey except for the small area you're standing in. moving the map will result in that area
    being erased, in a way. map cannot be moved.

    Like I said, to me, this isn't exactly critical, but it would still be good to know why, especially if this happens to others.

  2. #2
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    8,595
    Rep Power
    1
    Logs from the crash. Logs from after the crash. Logs from the clients. Information on how the server is configured. Information on what caused the crash. There's a lot missing from your report.

    You might take a gander at reading the sticky thread that tells you to read it before starting a new thread.

  3. #3
    Ranger Ti2xGr's Avatar
    Join Date
    Jul 2017
    Location
    Bend, Oregon
    Posts
    315
    Rep Power
    1
    As mentioned, logfiles helpful. That said, I've had this happen to me numerous times (Hosting on a Windows 10 Desktop system). Exact symptoms - No trees, map greyed out, wierd glitches in the visuals (can't see towns on the horizon, etc). Every time I've been able to fix this, it was rolling back the main.ttw file that ended up repairing the issue. During the initial crash, it looks like the Main.ttw file was corrupted and then on reload, backed up the corrupt file (much smaller than the saved file). Since then, we aggressively backup - Every hour we snapshot the entire directory. We did not have to restore the map or users - Just the Main.ttw file from earlier in the game. From the looks of it, the main.ttw was basically reset to ground zero during the crash. Side note, often - a user would also be reset to level 1 again despite their base still intact. This was, until we rolled back that file. Then, everything was right in the world again. Any which way, it was/is fixable for us.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •