Page 3 of 23 FirstFirst 1234513 ... LastLast
Results 31 to 45 of 337

Thread: Project Slaanhatten

  1. #31
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    Quote Originally Posted by Doombringer101 View Post
    Just watched the video
    Extremely impressive work Slaan!
    Cheers dude!,

    On a side note, my master copy has ported over to the 13.7 mixer and the de-sync problem still persists. Got most of the upcoming concept areas almost done but gonna put the rest on hold for now and start trying to track down the cause of this issue. Theres quite clearly particular trouble spots, I had tried resetting all densities back to 0 for the hub and was getting a crash to desktop (no error, just client closing instantly)when trying to generate some parts so gonna do some more controlled testing with smaller areas and see what that brings.

  2. #32
    Refugee
    Join Date
    Oct 2014
    Location
    Warsaw, Poland
    Posts
    27
    Rep Power
    0
    Just a quick feedback: I've been playing with friends on a dedicated server with a map generated with your code (having your code removed afterwards) and there were no desync or other issues of that kind.

    I'm still yet to test your code on a dedicated server again to double check the desync issue, but I'm working 24/7 atm so I don't have much time for gaming...

  3. #33
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    2016-01-29T18:01:16 809.840 ERR Task_CommWriterSteam (cl=76561198005426512, ch=0):

    2016-01-29T18:01:16 809.840 EXC offset+count

    Parameter name: The size of the buffer is less than offset + count.

    ArgumentException: offset+count

    Parameter name: The size of the buffer is less than offset + count.
    at System.IO.MemoryStream.Read (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0

    at NetConnectionSteam.Task_CommWriter (.TaskInfo _threadInfo) [0x00000] in <filename unknown>:0
    UnityEngine.Debug:Internal_LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    Logger:masterLogException(Exception)
    Logger:Exception(Exception)
    Log:Exception(Exception)
    NetConnectionSteam:Task_CommWriter(TaskInfo)
    ThreadManager:W(Object)
    Ok so after a few tries, managed to capture the error (as the host of local MP), any idea's or suggestions would be appriciated as although there does seem to be a way to work around this for the dedi server, the offset + count thing seems to be quite specific and is not an error im used to seeing.

    The steam ID at the top is the player who connected, he received the keynotfound error seconds before this one popped up at my end, and from that point on terrain refuses to generate for him, both our cursors are gone and the game requires a full restart to fix. Below is the error log from his end.

    2016-01-29T18:00:35 183.841 INF ************************ SKY INITIALIZED ************************

    2016-01-29T18:00:36 184.173 INF PlayerId(258, 0)

    2016-01-29T18:00:36 184.589 INF Created player with id=258

    2016-01-29T18:00:36 184.600 INF Found own player entity with id 258

    2016-01-29T18:00:36 184.608 INF Adding observed entity: 1, (1666.9, 64.0, 1666.9), 8

    2016-01-29T18:00:36 184.711 INF Created player with id=239

    2016-01-29T18:00:36 184.727 INF GMSG: Mr T-Ball joined the game

    2016-01-29T18:00:58 206.940 ERR Task_CommReaderSteam (ch=0):

    2016-01-29T18:00:58 206.941 EXC The given key was not present in the dictionary.

    KeyNotFoundException: The given key was not present in the dictionary.
    at System.Collections.Generic.Dictionary`2[NetPackageType,System.Type].get_Item (NetPackageType key) [0x00000] in <filename unknown>:0

    at NetPackage.Parse (System.IO.BinaryReader _reader, .ClientInfo _sender) [0x00000] in <filename unknown>:0

    at NetConnectionSteam.Task_CommReader (.TaskInfo _threadInfo) [0x00000] in <filename unknown>:0
    UnityEngine.Debug:Internal_LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    Logger:masterLogException(Exception)
    Logger:Exception(Exception)
    Log:Exception(Exception)
    NetConnectionSteam:Task_CommReader(TaskInfo)
    ThreadManager:W(Object)

    (Filename: Line: -1)

    2016-01-29T18:01:16 224.446 INF Time: 2.64m FPS: 39.26 Heap: 286.5MB Max: 286.5MB Chunks: 256 CGO: 196 Ply: 2 Zom: 0 Ent: 3 (23) Items: 20 CO: 1

    2016-01-29T18:01:46 254.476 INF Time: 3.14m FPS: 35.49 Heap: 286.8MB Max: 286.8MB Chunks: 256 CGO: 196 Ply: 2 Zom: 0 Ent: 3 (23) Items: 20 CO: 1

    2016-01-29T18:02:16 284.487 INF Time: 3.64m FPS: 50.87 Heap: 316.9MB Max: 316.9MB Chunks: 256 CGO: 196 Ply: 2 Zom: 0 Ent: 3 (23) Items: 20 CO: 1

    Unloading 2 Unused Serialized files (Serialized files now loaded: 2)

    Unloading 2594 unused Assets to reduce memory usage. Loaded Objects now: 244476.
    Total: 540.874451 ms (FindLiveObjects: 37.645477 ms CreateObjectMapping: 22.355980 ms MarkObjects: 474.594421 ms DeleteObjects: 6.276538 ms)

    2016-01-29T18:02:46 314.768 INF Time: 4.14m FPS: 18.89 Heap: 296.1MB Max: 316.9MB Chunks: 256 CGO: 196 Ply: 2 Zom: 0 Ent: 3 (23) Items: 20 CO: 1

    2016-01-29T18:03:00 328.276 INF [Steamworks.NET] NET: Connection closed

    2016-01-29T18:03:00 328.281 INF [NET] DisconnectedFromServer: Connection closed by server

    2016-01-29T18:03:00 328.286 INF SaveAndCleanupWorld

    2016-01-29T18:03:05 333.172 INF XUI loading took 4833ms

    2016-01-29T18:03:05 333.174 INF [Steamworks.NET] Stopping server

    2016-01-29T18:03:05 333.194 INF World.Unload

    2016-01-29T18:03:05 333.333 INF World.Cleanup

    2016-01-29T18:03:05 333.335 INF Exited thread thread_Regenerating

    2016-01-29T18:03:05 333.335 INF Exited thread RY

    2016-01-29T18:03:05 333.336 INF Removing observed entity 1

    2016-01-29T18:04:18 406.789 INF Persistent GamePrefs saved

    2016-01-29T18:04:18 406.791 INF Cleanup

    Unloading 1 Unused Serialized files (Serialized files now loaded: 2)

    Unloading 21456 unused Assets to reduce memory usage. Loaded Objects now: 191806.
    Total: 329.443481 ms (FindLiveObjects: 33.010853 ms CreateObjectMapping: 25.117855 ms MarkObjects: 229.239197 ms DeleteObjects: 42.073547 ms)

    2016-01-29T18:04:19 407.651 INF OnApplicationQuit
    The keynotfound thing, I have seen before but as I'm certain the mixer itself is not at fault, I had thought it could have been a density thing but have ruled this out now as I have reset all densities to 0 (except air, that was changed back to 127) and while there are less glitches in some seeds, the hub is loading fine for me.

    It's almost like there's a null block hiding somewhere, but that would surely cause me issues long before any others connected.

  4. #34
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    Quote Originally Posted by Psyborg View Post
    Just a quick feedback: I've been playing with friends on a dedicated server with a map generated with your code (having your code removed afterwards) and there were no desync or other issues of that kind.

    I'm still yet to test your code on a dedicated server again to double check the desync issue, but I'm working 24/7 atm so I don't have much time for gaming...
    All info is appreciated m8 and you have given me a workaround to test. Obviously I'd like to know what is causing the problems, but a solid workaround means people can still enjoy at least!

  5. #35
    Refugee
    Join Date
    Oct 2014
    Location
    Warsaw, Poland
    Posts
    27
    Rep Power
    0
    EXC offset+count
    Parameter name: The size of the buffer is less than offset + count.
    The above error is exactly the one I was having when running a locally hosted MP. However the error occured only when another player has connected.
    From what I've found, it may be somehow related to a PNG encoder used to compress/decompress large png files, but it may be as well a bug in the game code...
    I have a little clue why is it occuring only in an MP game and only with clients connected:

    From what I see i the server log file, the whole "thing" starts with an error related to communication protocol with Steam (ERR Task_CommWriterSteam)- I guess this is some netcode issue.

    Then the desync and client crashing due to "KeyNotFound" thing is just a result of the broken communication with the server.

    Just an idea...

    EDIT:
    https://steamcommunity.com/app/25157...4254452569207/

  6. #36
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    I've broken the hub apart for the time being, slowly re-doing the roads and putting it back together piece by piece. More importantly BigC has let me use the northern lan test server and the downtown area is loading up fine, not been kicked or de-synced at all so far. It's gonna take a couple of days to get it all back together, testing each area on the dedi server before moving on to the next parts.

    I should be putting out the next version during the week if all goes well, the access ramp prefabs I made for the highway really start to bring the two halfs of the hub together now they are joined by the bridge, lowfdogs arena has had it's foundations set and will be the main show off on the south side in the next release.

  7. #37
    Refugee
    Join Date
    Oct 2014
    Location
    Warsaw, Poland
    Posts
    27
    Rep Power
    0
    Can't wait for the update. I love it. Can't imagine I could have played without it.

    P.S. Are you planning to change the layout of the city? Me & my friends made a base in the bank at the NW edge and I'd hate to build it from scratch again.

  8. #38
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    They layout will stay the same, the major changes will be the additions like the south side of the river, highway + bridge with the access ramps. I think downtown is gonna extend another block so I can squeeze in a school and wrap that area up as its own 'little' district.

    As I'm still not sure whats causing the initial problem I'm expecting the addition of a section will break something at some point, but when it does I'll be in a better position to diagnose what I done wrong re-building it piece by piece. There's floaty islands all over atm too, but I'll work on them once the hub is whole again.

  9. #39
    Colony Founder DieTillDay7's Avatar
    Join Date
    Oct 2015
    Posts
    1,221
    Rep Power
    1
    looked at this - and its pretty good - great job - to be honest i could help with building - but currently my time is modding - but if i get that done i have another project with another modder - but i will pop in now and again and see what you have done and maybe when im done modding ill come help you - but for now keep up the good work!

  10. #40
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    Quote Originally Posted by DieTillDay7 View Post
    looked at this - and its pretty good - great job - to be honest i could help with building - but currently my time is modding - but if i get that done i have another project with another modder - but i will pop in now and again and see what you have done and maybe when im done modding ill come help you - but for now keep up the good work!
    People are welcome at any stage to do as little or as much as they like, or just ping back feedback/suggestions here and I'll add the good ones to the 'to do' list. It's the prefabbers who have crazy big builds that will feel most at home as instead of filling all our cell's with tiny custom hubs we can collect them all together in one place and leave our random gen a bit more 'random'.

    On a sidenote, I've not been able to track down the cause of the error's we've been saying, I will speculate some things regarding it tho. Firstly, initial testing started on a dedi server went perfectly fine, up until the hub was around 4 x 4 prefab lots. As it gets to this kind of size, the hub itself if too big to fit into terrain and we start to see hill's etc be removed when the hub is placed into the world. This is the start of the triangle fails, some seeds are terrible, a handful are not so bad, but the ground level of the hub sitting over the terrain as opposed to cutting thru it defo see's much better results. How this is tied to the de-sync error is beyond me, I'm a self confessed simpleton and I've tried rebuilding piece by piece, there's nothing that stands out as the obvious issue when I first hit seeds that produced the error.

    I'm still to test Psyborgs' work around, but once the last parts of the hub are re-added (taking longer than expected, but a lot of cleaning up has been done) I'll take a look at it in more detail and include instructions (and probably a video) on how to set it up on a dedicated server.

    All in all, it's looking much better and I can't wait to get the rest of the highway ramps set in and get the last couple of concept area's finished off.

  11. #41
    Leader
    Join Date
    Mar 2014
    Location
    Brisbane, Australia
    Posts
    6,820
    Rep Power
    1
    i am currently building some skyskrapers. Also going to be a part of my hospital. But if all works out ot should be able to be swapped and changed into different buildings (using the editor ofc). However wont be able to export til hals is updated. But still got lots to do before this is finished

  12. #42
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    Quote Originally Posted by stallionsden View Post
    i am currently building some skyskrapers. Also going to be a part of my hospital. But if all works out ot should be able to be swapped and changed into different buildings (using the editor ofc). However wont be able to export til hals is updated. But still got lots to do before this is finished
    Sounds interesting, good thing with having to wait for the dll's is it's given me a ton of time to go over every city section in the editor to correct all sorts of crap, I fear rotations are not fully eliminated... forgot the brownstone houses had pipes in the basement >.< but it's looking a lot tidier now.

  13. #43
    Refugee
    Join Date
    Oct 2014
    Location
    Warsaw, Poland
    Posts
    27
    Rep Power
    0
    Any news? ETA?

  14. #44
    Zombie Hunter
    Join Date
    Aug 2015
    Posts
    414
    Rep Power
    1
    I've done feck all for about 5 days lol, but now the editor is updated Im gonna crack on with whats left to do for this version. No ETA yet, but I think I'm gonna skip the downtown addition I mentioned earlier and use it as the basis for a couple tutorials on how to add new area's to the project.

    Northern highway needs it's access ramps put in, but they are already pre-built and just need inserted/tidied up, all of the highway prefabs (5 roads, 4 ramps) make up a tidy little set that will be there with the mini-fabs should anyone want to use them for anything. Once the highway is complete I'll look at any other little touch ups I can do, then crack on with the dedi server setup/testing.

  15. #45
    Refugee
    Join Date
    Feb 2016
    Posts
    1
    Rep Power
    0

    Awesome job man!

    Quote Originally Posted by Slaan View Post
    Ok sorry about that, It's the first time I've had to roll the project back, my version includes lowfdogs area and some other 'blank' spots that are the foundation for whats been drawn into the next version's concept map and I had not fully removed all the unused entries.

    The link has been updated with the corrections in the mixer, let me know if you have any other troubles.

    Forgot to add that people are more than welcome to include this in their own packs, It will be easy enough to update the prefab sections as I release newer versions, and there will always be a fresh mixer included for those who want to add the new stuff from each update.
    I am new to the whole prefab and modding community myself, but my friend and I are quickly learning how to do these prefabs. We both greatly enjoy building detailed structures, and I also like the 3d character work in blender. I don't have the dedicated server to export anything to, but if you're interested in help or offers to add some newer buildings and such let me know, I will have you jump on with me and check out the missile silo I just started

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •