Page 83 of 114 FirstFirst ... 3373818283848593 ... LastLast
Results 1,231 to 1,245 of 1698

Thread: The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

  1. #1231
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by Cadamier View Post
    Weird... This is the 2nd or 3rd time its happened to me. Last night I played Valmod. Then this morning I closed 7D2D and then selected War of the Walkers (Left tree window) and tried to play (far right "Play Mod"), during creating player it gave me: "IndexOutOfRangeException: Array index is out of range." errors. Once I spawned into the game it said "Welcome to Valmod." Last time the save was corrupted, this time after spawning in as "valmod" I exited and just checked save by logging in with War of the Walkers and entire inventory is lost with the exception of the Land Claim Block... Base and stuff still there but character is back at level 1.

    Launcher: https://pastebin.com/7FTFdyWK
    War of the Walkers: https://pastebin.com/7h9AS5Pa

    Those are the only logs listed.
    EDIT: Day has not reset and is at 23, quest log is empty.
    Did you connect to a Valmod server with War of the Walkers mod installed locally?

  2. #1232
    Zombie Hunter Kam R.'s Avatar
    Join Date
    Apr 2017
    Posts
    436
    Rep Power
    1
    Quote Originally Posted by tbonepat11 View Post
    (...)
    INFO 4 _7D2DLauncher.frmMain - System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
    at System.Net.WebClient.DownloadFile(Uri address, String fileName)
    at _7D2DLauncher.frmMain.DoDownload(String strDownload)

    (...)
    Ah, looks like i'm not just stupid and the only one with this problem..

    Getting this error, with any mod I try to install. No exceptions.
    Log excerpt if it's of any help (it basically repeats the same entries with every following install attempt, so I didn't put the full wall of text in.):
    https://pastebin.com/bmByR1RQ

    My typical luck with these things lol. Today I finally decide to check out some mods extensively and find this launcher. And since I'm very lazy and hate the file juggling when switching mods I'm happy it exists. Hope you get it up and running again soon and thanks for your work!

  3. #1233
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by Kam R. View Post
    Ah, looks like i'm not just stupid and the only one with this problem..

    Getting this error, with any mod I try to install. No exceptions.
    Log excerpt if it's of any help (it basically repeats the same entries with every following install attempt, so I didn't put the full wall of text in.):
    https://pastebin.com/bmByR1RQ

    My typical luck with these things lol. Today I finally decide to check out some mods extensively and find this launcher. And since I'm very lazy and hate the file juggling when switching mods I'm happy it exists. Hope you get it up and running again soon and thanks for your work!
    Oh it's definitely not something you are doing

    GitHub dropped SSL support yesterday, which was kind of old protocol anyway, and just allow TLS1.2 now. Unfortunately, the different versions of .NET and windows has wonky support for that protocol. I'm playing around with some releases today to try to fix it, but it seems if you have the latest version of the .NET 4 installed, it'll work better.

    The Mod Launcher should auto-update to this in 1.0.4.7 or higher.

  4. #1234
    Zombie Hunter gpcstargate's Avatar
    Join Date
    Jun 2016
    Location
    Virginia, USA
    Posts
    469
    Rep Power
    1
    Sphereii .. Afternoon

    Has it been update yet ?? Main page is still showing " Update Version 1.0.4.6 - January 4th, 2018 " ........ Just wondering before going into Launcher.

    Have a good one..........

  5. #1235
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1

    Attention Windows 7 Users!

    Due to GitHub changing from SSL to TLS, the Mod Launcher had to update in order to authenticate to download! This is available in the new Mod Launcher verison 1.0.4.8 and Higher.

    However, for Windows 7, TLS support is *not* enabled by default.

    Microsoft has an easy to use program to enable it:

    1) Download their tool: https://download.microsoft.com/downl...syFix51044.msi

    2) Run the Tool and apply the EasyFix

    3) Reboot your computer ( Do not skip this step, otherwise it won't work)

    This is a one-time program to run, and only if you are running Windows 7.

    All current versions of Windows are compatible with TLS by default (8, 10).

    If you still get a message about Required .NET Framework upgrade, and it does not install it automatically, download it here: https://www.microsoft.com/en-ca/down....aspx?id=49981

    I thank you all for your patience over the last 24 hours that this change was pushed out, and please let me know if any mods still does not work for you.
    Last edited by sphereii; 02-25-2018 at 12:40 PM.

  6. #1236
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by gpcstargate View Post
    Sphereii .. Afternoon

    Has it been update yet ?? Main page is still showing " Update Version 1.0.4.6 - January 4th, 2018 " ........ Just wondering before going into Launcher.

    Have a good one..........
    Done, kind sir! I pushed the release a few hours ago, and things seem to be going well for the affected users.

  7. #1237
    Ranger
    Join Date
    Feb 2017
    Posts
    309
    Rep Power
    0
    Hi sphereii! I just came back to 7DTD after a small break, and the mod launcher suddenly fails at every download. I tried to update/DL several different mods (your Winter Mod, Tins Dying Lands, and now Starvation). They all just repeatedly throw "Error Downloading... Clearning corrupted data.". I was hoping your update today would help, but unfortunately it didn't fix this particular error. I'm on Win7 and also applied the EasyFix. I also already tried temporarily disabling my antivirus program completely. This is the log: https://pastebin.com/eP0u1pK0
    I know I can just download the full mods directly, but I have really come to rely on the launcher's incremental updates, to make comparing and updating with my own file changes easier.

  8. #1238
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by owl79 View Post
    Hi sphereii! I just came back to 7DTD after a small break, and the mod launcher suddenly fails at every download. I tried to update/DL several different mods (your Winter Mod, Tins Dying Lands, and now Starvation). They all just repeatedly throw "Error Downloading... Clearning corrupted data.". I was hoping your update today would help, but unfortunately it didn't fix this particular error. I'm on Win7 and also applied the EasyFix. I also already tried temporarily disabling my antivirus program completely. This is the log: https://pastebin.com/eP0u1pK0
    I know I can just download the full mods directly, but I have really come to rely on the launcher's incremental updates, to make comparing and updating with my own file changes easier.
    Welcome back Sorry you are running into the error.

    Have you rebooted since you applied the EasyFix? I usually avoid rebooting when I'm told to, but in this case it's necessary. The EasyFix updates a few registry values to enable the TLS.

  9. #1239
    Ranger
    Join Date
    Feb 2017
    Posts
    309
    Rep Power
    0
    Yes I did reboot, the log was taken after updating, easyfix and rebooting, and with Avast disabled.

  10. #1240
    Refugee nemo888's Avatar
    Join Date
    Apr 2017
    Location
    UK
    Posts
    14
    Rep Power
    0
    The 7D2DModLauncher has stopped working for me too ('System Update Required: Unable to run or install this application. This application requires version 4.6.1 Full or other compatible .NET Framework').

    It was working last night (Sat 24th Feb / War of The Walkers), but not this morning.

    I've tried installing the EasyFix but no success (still getting the 'system update required' error).

    I'm running Windows 7 (Avast Disabled / Installed msi through elevated command prompt / reboot)
    Last edited by nemo888; 02-25-2018 at 11:56 AM.

  11. #1241
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by owl79 View Post
    Yes I did reboot, the log was taken after updating, easyfix and rebooting, and with Avast disabled.
    Quote Originally Posted by nemo888 View Post
    The 7D2DModLauncher has stopped working for me too ('System Update Required: Unable to run or install this application. This application requires version 4.6.1 Full or other compatible .NET Framework').

    It was working last night (Sat 24th Feb / War of The Walkers), but not this morning.

    I've tried installing the EasyFix but no success (still getting the 'system update required' error).

    I'm running Windows 7 (Avast Disabled / Installed msi through elevated command prompt / reboot)
    Did the .NET auto-install? Here's the link for a manual install: https://www.microsoft.com/en-ca/down....aspx?id=49981

  12. #1242
    Scavenger
    Join Date
    Oct 2016
    Posts
    35
    Rep Power
    0
    Great tool Sphereii , it makes our life mush easier.

    Is there a way to prevent the launcher from copying mod files every launch?

  13. #1243
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by Hydr0 View Post
    Great tool Sphereii , it makes our life mush easier.

    Is there a way to prevent the launcher from copying mod files every launch?
    There's a few things you can do. By design, it wants to over-write and keep everything up to date, because running an out of date mod is potentially against what the modder wants.

    However, for people who love tweaking, it's a bit of a challenge. Here's a few things you can do, and you may choose what works best for you.

    [ Simple and Easy ]
    1) Make your changes under TempMods. Then, uncheck the Refresh Mods automatically, and play as normal.

    2) Make your changes as you normally would, and run the 7daystodie.exe manually, skipping the Mod Launcher completely.

    [ Advanced ]

    3) Make your changes in the files, then host the files somewhere, and create a My mod to download the full mod, then download your changes.

  14. #1244
    Zombie Hunter Kam R.'s Avatar
    Join Date
    Apr 2017
    Posts
    436
    Rep Power
    1
    The Win7 related fix seems to have done the trick. Many thanks!

  15. #1245
    Colony Founder sphereii's Avatar
    Join Date
    Dec 2015
    Posts
    3,108
    Rep Power
    1
    Quote Originally Posted by Kam R. View Post
    The Win7 related fix seems to have done the trick. Many thanks!
    Glad it worked for you!

    The love of Windows 7 is still strong; and the distrust of 8/10 even stronger, it seems.

    Fun Facts!

    Windows 7 was released in 2009, with 8 appearing in 2012 and 10 in 2015.

    Mainstream support ended on January 13, 2015.
    Extended support ends on January 14, 2020.
    Installing Service Pack 1 is required for users to receive updates and support after April 9, 2013.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •