Page 3 of 15 FirstFirst 1234513 ... LastLast
Results 31 to 45 of 212

Thread: A16 - Custom Vehicles by Manux [SDX]

  1. #31
    Refugee
    Join Date
    Jun 2018
    Location
    Croatia
    Posts
    28
    Rep Power
    0
    I get this error:

    https://imgur.com/Y1sC4fM

    How to fix it?
    Thanks for help

  2. #32
    Guppycurian Forum Whore Guppycur's Avatar
    Join Date
    Apr 2014
    Location
    Enemy for life
    Posts
    22,505
    Rep Power
    1
    Sweet...

  3. #33
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    Quote Originally Posted by tin33cro View Post
    I get this error:

    https://imgur.com/Y1sC4fM

    How to fix it?
    Thanks for help
    Hi there, couple of questions and recommendations:
    - Does your output_log.txt file give you more details on the errors? This file can typically be found here with a default SDX setup: C:\SDXModding\Game\Working\7DaysToDie_Data
    - Can you spawn the full vehicles with the Spawn Entity window (F6 when in debug mode (dm))?
    - Make sure you use the latest SDX Launcher version 0.72 or 0.72c for deploying the mod. This also applies for installing any of my other mods.
    - If you are new to SDX, make sure to read/do the SDX tutorials.
    Last edited by manux; 10-08-2018 at 08:39 PM.

  4. #34
    Refugee
    Join Date
    Jun 2018
    Location
    Croatia
    Posts
    28
    Rep Power
    0
    Thanks for help..
    In output.log.txt I find this:

    2018-10-09T00:25:29 140.083 INF Time: 1.88m FPS: 73.70 Heap: 801.1MB Max: 801.1MB Chunks: 530 CGO: 324 Ply: 1 Zom: 0 Ent: 1 (1) Items: 0 CO: 1 RSS: 3498.8MB
    NullReferenceException: Object reference not set to an instance of an object
    at XUiC_SpawnMenu.BBG (Int32 ) [0x00000] in <filename unknown>:0
    at XUiC_SpawnMenu+QE.WZ (.XUiController , .OnPressEventArgs ) [0x00000] in <filename unknown>:0
    at (wrapper delegate-invoke) XUiEvent_OnPressEventHandler:invoke_void__this___X UiController_OnPressEventArgs (XUiController,OnPressEventArgs)
    at XUiController.OnPressed (.OnPressEventArgs _e) [0x00000] in <filename unknown>:0
    at XUiController.Pressed (Int32 mouseButton) [0x00000] in <filename unknown>:0
    at XUiView.NGuiButtonOnClick (UnityEngine.Transform _t) [0x00000] in <filename unknown>:0
    at NGuiButtonOnClickHandler.OnClick () [0x00000] in <filename unknown>:0
    UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
    UICamera:Notify(GameObject, String, Object)
    UICamera:ProcessTouch(Boolean, Boolean, Boolean)
    UICamera:ProcessMouse()
    UICamera:ProcessTouches()
    UICamera:Update()

    In Spawn entity window when I try to spawn full vehicle,the same error shows; "NullReferenceException: Object reference not set to an instance of an object"
    I read the whole sdx tutorial and do everything that said there. Other sdx mods working fine...

  5. #35
    Colony Founder DUST2DEATH's Avatar
    Join Date
    Jun 2014
    Location
    AU - HDHQ Overhaul
    Posts
    1,875
    Rep Power
    1
    All vehicles or just the quad?

  6. #36
    Refugee
    Join Date
    Jun 2018
    Location
    Croatia
    Posts
    28
    Rep Power
    0
    Quote Originally Posted by DUST2DEATH View Post
    All vehicles or just the quad?
    With all vehicles I get the same error.I tried reinstall everything but no luck.

  7. #37
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    Ok I think you are right tin33cro, I just tested the mod on its own without any other mods installed and I do get the same error. So this means I have dependencies to another mod I'm using and I didn't know about it.
    I have a feeling it's gonna be something like Hal's DLL fixes mod.
    Let me isolate the problem and get back to you shortly...

  8. #38
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    Ok it was exactly what I thought.
    You need to also deploy Hal's DLL fixes mod for my mod to work.
    You can grab it here if you don't already have it:
    https://github.com/7D2DSDX/Mods/tree.../HalDllUpdates

    Thanks a lot for catching this and reporting it to us, I had no clue I had dependencies. I always use Hal's DLL fixes mod, it's a good mod to always have.
    I'll update my mod to have a dependency and add a note in the mod's readme.

  9. #39
    Colony Founder DUST2DEATH's Avatar
    Join Date
    Jun 2014
    Location
    AU - HDHQ Overhaul
    Posts
    1,875
    Rep Power
    1
    OP updated.

  10. #40
    Refugee
    Join Date
    Jun 2018
    Location
    Croatia
    Posts
    28
    Rep Power
    0
    @manux
    I can confirm that mod is working now without problems
    Thank you for help and quick fixing the problem. Keep up the good work and make many good mods

  11. #41
    Scavenger
    Join Date
    Apr 2018
    Posts
    34
    Rep Power
    0
    awsome mod dude!!

  12. #42
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    Happy it now works guys, and happy you like it!

    There's more vehicles coming. I'm working on a big construction loader now.
    https://skfb.ly/6toGS

  13. #43
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    All right guys, the new toy is up and running, and pretty awesome!
    code is submitted on github.
    Keep an eye on improvements added to this mod, they are happening pretty often right now, I'm on fire.


    Last edited by manux; 10-10-2018 at 05:26 AM.

  14. #44
    Tracker manux's Avatar
    Join Date
    Jul 2018
    Posts
    205
    Rep Power
    1
    I've also added more documentation about the mod in it's readme:
    https://github.com/manux32/7dtdSdxMo...CustomVehicles

  15. #45
    Tracker Mumpfy's Avatar
    Join Date
    Feb 2018
    Posts
    204
    Rep Power
    1
    wow, amazing work. that thing needs bumper stickers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •