Results 1 to 10 of 10

Thread: Performance Quirks

  1. #1
    Refugee
    Join Date
    Jun 2017
    Posts
    29
    Rep Power
    0

    Performance Quirks

    I really just don't get the performance of A17. It seems to run oddly. It never leverages an entire core of my cpu but my framerate drops into the 30s. It's not a gpu issue either as it doesn't seem to bottleneck there either. That's not even mentioning that it seems to be predominantly zombie spawns that do it. That would be more of a cpu issue. Why then do I lose fps when no core is above 60%? I don't get this game. I'm attaching an image that shows this. I've found a couple things odd with the overlay, so there's a chance it's that but for the most part that was just the freqs. Nothing shows that same freqs for the gpu. The rest has been accurate so I trust the overlay. Thirty-six frames with nothing maxed makes no sense.

    framerate issues 3.jpg

  2. #2
    Ranger
    Join Date
    Feb 2017
    Location
    Above dirt
    Posts
    348
    Rep Power
    1
    A17 experimental is unplayable for me. I have a beefy machine with 4 cores, 16gb RAM, 8gb GPU and a high quality SSD. My game also drops to 30 FPS and sometimes high 20's FPS. Even tried the absolute lowest settings and still same problems.

    That type of FPS makes me physically ill.

    Word of advice for the Fun Pimps, something a boss taught me about 15 years ago:

    The number one way to get developers to produce a product with good performance is NOT let the programmers develop using the latest/greatest fastest hardware. Give the developers old pieces of crap to develop on. They will then develop with performance in mind every piece of code instead of retroactively coming back to fix performance latter.

    I could honestly care less about all the game play changes. Some sound good, some of the changes sounds great...but.. The gameplay doesn't matter at all if the game is unplayable due to FPS.

  3. #3
    Ranger R0bb0b's Avatar
    Join Date
    Dec 2014
    Posts
    285
    Rep Power
    0
    Quote Originally Posted by fragtzack View Post
    A17 experimental is unplayable for me. I have a beefy machine with 4 cores, 16gb RAM, 8gb GPU and a high quality SSD. My game also drops to 30 FPS and sometimes high 20's FPS. Even tried the absolute lowest settings and still same problems.

    That type of FPS makes me physically ill.

    Word of advice for the Fun Pimps, something a boss taught me about 15 years ago:

    The number one way to get developers to produce a product with good performance is NOT let the programmers develop using the latest/greatest fastest hardware. Give the developers old pieces of crap to develop on. They will then develop with performance in mind every piece of code instead of retroactively coming back to fix performance latter.

    I could honestly care less about all the game play changes. Some sound good, some of the changes sounds great...but.. The gameplay doesn't matter at all if the game is unplayable due to FPS.
    I have a decent machine i7 4th edition but gets over 4 GZ per, so I would consider that still a pretty beefy cpu. Gpu gtx760, which is not the best, but that said, I get exactly the same performance as you've described. Of course the game gets like this pretty much every other alpha release. The Pimps recreate the game every other alpha and then improve performance the next it seems like.
    Last edited by R0bb0b; 5 Days Ago at 07:26 AM.

  4. #4
    Hunter InSanity's Avatar
    Join Date
    Dec 2014
    Location
    Lost in the Woods
    Posts
    131
    Rep Power
    0
    I've got a gtx 1060 6 gb graphics card, i5 8600k cpu at 3.6 ghz without overclock, and 16gb of ram and I'm on 1600x900 at pretty much maxed out settings save 1 or 2 turned off and 1 on high instead of ultra and I consistently get 90+ fps outside and around 70 or so once I go into a poi. A couple days ago (still on b208) I was playing on medium settings with even more things turned off and get only around 60 frames but I changed some minor settings in the nvidia control panel and now it's running smoothly. The options I changed are in another thread a day or so back titled something along the lines of how are you guys running the experimental with no lag.

  5. #5
    Refugee
    Join Date
    Oct 2018
    Posts
    18
    Rep Power
    0
    got 8 cores and a 1080 same issue

  6. #6
    Colony Founder
    Join Date
    Mar 2017
    Posts
    1,474
    Rep Power
    1
    Quote Originally Posted by Stranded_Napkin View Post
    I really just don't get the performance of A17. It seems to run oddly. It never leverages an entire core of my cpu but my framerate drops into the 30s. It's not a gpu issue either as it doesn't seem to bottleneck there either. That's not even mentioning that it seems to be predominantly zombie spawns that do it. That would be more of a cpu issue. Why then do I lose fps when no core is above 60%? I don't get this game. I'm attaching an image that shows this. I've found a couple things odd with the overlay, so there's a chance it's that but for the most part that was just the freqs. Nothing shows that same freqs for the gpu. The rest has been accurate so I trust the overlay. Thirty-six frames with nothing maxed makes no sense.

    framerate issues 3.jpg
    There are more possible bottlenecks than CPU and GPU. For example the data exchange rate between CPU and GPU or the memory transfer rate. Or the PCI bus transfer rate

    Since a lot of people with faster machines also sometimes report problems (depending on the version of their graphics driver and their settings) I suspect it might be a combination of one of the above (because neither exchange rate nor memory transfer rate have been doing big jumps in the last years) and an unusually high use of some seldom used functions of the graphics drivers. Just a wild guess though

  7. #7
    Community Moderator SylenThunder's Avatar
    Join Date
    Oct 2014
    Location
    SE Michigan, out in the sticks.
    Posts
    7,274
    Rep Power
    1
    It's also the fact that this is an Experimental version of an Alpha release that isn't finished yet.

    People seem to keep overlooking this simple fact, and expect something more polished than it should be.

  8. #8
    Tracker
    Join Date
    Sep 2016
    Posts
    243
    Rep Power
    1
    Quote Originally Posted by SylenThunder View Post
    It's also the fact that this is an Experimental version of an Alpha release that isn't finished yet.

    People seem to keep overlooking this simple fact, and expect something more polished than it should be.
    And TFP moderators and staff are good at making excuses...

    Its a experimental ( of a 16 months ) developed alpha, of a game that is under development for the last 5+ years.

    As my mother used to say: Excuses only last you so long.

    The issue with Zombies spawn dropping the framerate is something we did not have until UMA zombies. Those UMA zombies got removed. And yet now we have Zombie spawn stutters again. My guess is the AI pathing per zombie being too complex and stalling the CPU on every spawn.

    And while the new AI zombies are great for getting out of houses, they actually have major issues.

    * Conga lines making them easier to kill.

    * They are smart and yet it making them so easy to misuse.

    Before they brute forced on buildings, so you needed a lot of defenses everywhere. Now you can literally path them down the "easy" open way.

    My personal recommendation is to add variety. Some Zombies with the new pathing, others with the old. Give zombies with the old pathing more health and block damage to compensate. It makes it more challenging and they act more unpredictable. It also reduces the CPU burden.

  9. #9
    Tracker SurvivalUK's Avatar
    Join Date
    Aug 2016
    Posts
    249
    Rep Power
    1
    Quote Originally Posted by SylenThunder View Post
    It's also the fact that this is an Experimental version of an Alpha release that isn't finished yet.

    People seem to keep overlooking this simple fact, and expect something more polished than it should be.
    So after more than a year since the last update to get a nose dive in performance is reasonable? Thought updates are meant to improve things not take them backwards.

  10. #10
    Community Moderator OzHawkeye's Avatar
    Join Date
    Sep 2014
    Location
    Australia
    Posts
    3,925
    Rep Power
    1
    Nearly identical thread here: https://7daystodie.com/forums/showth...85-Performance

    So, locking this one up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •